From: Lars-Peter Clausen <lars@metafoo.de>
Date: Sun, 7 Jul 2013 20:22:35 +0000 (+0000)
Subject: i2c-tools: Pass LDFLAGS
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=b6a50b769977f54eef4de2fdb96e0410b0f9685d;p=openwrt%2Fsvn-archive%2Fpackages.git

i2c-tools: Pass LDFLAGS

Pass LDFLAGS when building the i2c-tools. This fixes the build under certain
exotic configurations.

SVN-Revision: 37188
---

diff --git a/utils/i2c-tools/Makefile b/utils/i2c-tools/Makefile
index 16feedb27..9ef752baa 100644
--- a/utils/i2c-tools/Makefile
+++ b/utils/i2c-tools/Makefile
@@ -68,7 +68,8 @@ define Build/Compile
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		LINUX="$(LINUX_DIR)" \
 		CC="$(TARGET_CC)" \
-		STAGING_DIR="$(STAGING_DIR)"
+		STAGING_DIR="$(STAGING_DIR)" \
+		LDFLAGS="$(TARGET_LDFLAGS)"
 	$(Build/Compile/python-smbus)
 endef