From: Nick Hainke <vincent@systemli.org>
Date: Thu, 4 May 2023 19:34:21 +0000 (+0200)
Subject: toolchain: glibc: increase min kernel version to 5.15
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=5bd7f04806d07a82e247220f2b825f4fcc43da9f;p=openwrt%2Fstaging%2Fldir.git

toolchain: glibc: increase min kernel version to 5.15

The purpose of this is to remove all of the compatibility code that is
normally compiled into glibc for kernels < 5.15 from our build. Only
Linux kernels >= 5.15 will be supported.

Signed-off-by: Nick Hainke <vincent@systemli.org>
---

diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index ac396531c9..33afb2d60a 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -64,7 +64,7 @@ GLIBC_CONFIGURE:= \
 		  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
 		  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
 		  $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
-		--enable-kernel=5.10.0
+		--enable-kernel=5.15.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no