From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 15 Jul 2017 20:51:25 +0000 (+0200)
Subject: sunxi: fix build of rtc package when module not available
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=4b81bb13f4005f243d14820a688150be5c350182;p=openwrt%2Fstaging%2Fsvanheule.git

sunxi: fix build of rtc package when module not available

If the Kconfig option CONFIG_RTC_DRV_SUNXI is not selected this package
should be be build.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99b82a3b5f..b8ea7d5cb6 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -10,8 +10,8 @@ define KernelPackage/rtc-sunxi
     DEPENDS:=@TARGET_sunxi
     $(call AddDepends/rtc)
     KCONFIG:= \
-	CONFIG_RTC_CLASS=y \
-	CONFIG_RTC_DRV_SUNXI=m
+	CONFIG_RTC_DRV_SUNXI \
+	CONFIG_RTC_CLASS=y
     FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
     AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
 endef