From: Mathias Kresin <dev@kresin.me>
Date: Mon, 17 Dec 2018 20:59:35 +0000 (+0100)
Subject: build: drop cameo-factory recipe
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=09004e6e13a85052cd56c58602d1300d6be52fc7;p=openwrt%2Fstaging%2Fansuel.git

build: drop cameo-factory recipe

The cameo factory images are created using existing image build
commands, which makes the code obsolete.

Signed-off-by: Mathias Kresin <dev@kresin.me>
---

diff --git a/include/image-commands.mk b/include/image-commands.mk
index 49138a216d..5e24c5e3aa 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -44,18 +44,6 @@ define Build/buffalo-dhp-image
 	mv $@.new $@
 endef
 
-# blow up binary to given size and put a given string at its end:
-# cameo-factory <size[k]> <string>
-define Build/cameo-factory
-	factory_stamp=$(word 2,$(1)); \
-	((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
-	( \
-		dd if=$@ bs=$$reduced_size conv=sync; \
-		echo -n $$factory_stamp; \
-	) > $@.new && \
-	mv $@.new $@
-endef
-
 define Build/eva-image
 	$(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
 	mv $@.new $@