From: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
Date: Mon, 12 Feb 2018 16:42:01 +0000 (+0300)
Subject: tools/mkimage: copy mkenvimage to bin directory
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=063fa4cfa28a6bdf502cebed3f984fc738bfad25;p=openwrt%2Fstaging%2Fsvanheule.git

tools/mkimage: copy mkenvimage to bin directory

For some boards u-boot binary environment file is required,
which is generated by mkenvimage utility. But in OpenWrt there
is no separate support for mkenvimage, which is a part of u-boot tools.
mkenvimage gets built in u-boot/tools as well as mkimage anyways.

So lets just copy mkenvimage to the $(STAGING_DIR_HOST)/bin/ directory.

Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
CC: Alexey Brodkin <abrodkin@synopsys.com>
CC: Hauke Mehrtens <hauke@hauke-m.de>
CC: John Crispin <john@phrozen.org>
---

diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index bfe60993e2..00f85ae272 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -37,10 +37,12 @@ endef
 
 define Host/Install
 	$(CP) $(HOST_BUILD_DIR)/tools/mkimage $(STAGING_DIR_HOST)/bin/
+	$(CP) $(HOST_BUILD_DIR)/tools/mkenvimage $(STAGING_DIR_HOST)/bin/
 endef
 
 define Host/Clean
 	rm -f $(STAGING_DIR_HOST)/bin/mkimage
+	rm -f $(STAGING_DIR_HOST)/bin/mkenvimage
 endef
 
 $(eval $(call HostBuild))