LHGG-60ad is IPQ4019 + wil6210 based. 80211ad
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 4 Jan 2021 23:22:00 +0000 (00:22 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 17 Jan 2021 08:38:50 +0000 (09:38 +0100)
Specification:

- Qualcomm IPQ4019 (717 MHz)
- 256 MB of RAM (DDR3L)
- 16 MB (SPI NOR) of flash
- 1x Gbit ethernet, 802.3af/at POE IN connected through AR8035.
- WLAN: wil6210 802.11ad PCI card
- No USB or SD card ports
- UART disabled
- 8x LEDs

Biggest news is the wil6210 PCI card.
Integration for its configuration and detection will be in other patches.

Install instructions:
Since ipq-aux-loader enables native support its installed like ar71xx RB boards.

Signed-off-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ipq40xx/base-files/etc/board.d/01_leds
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-lhgg-60ad.dts [new file with mode: 0644]
target/linux/ipq40xx/image/mikrotik.mk
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index 3e0f3ab25862ac6cd6f19273378b0ab6aa3eff07..70983986a55409a9121b9fe73dcf0998c5ca34a9 100755 (executable)
@@ -23,7 +23,8 @@ avm,fritzbox-4040)
        ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x1e"
        ;;
 avm,fritzbox-7530 |\
-glinet,gl-b1300)
+glinet,gl-b1300 |\
+mikrotik,lhgg-60ad)
        ucidef_set_led_wlan "wlan" "WLAN" "green:wlan" "phy0tpt"
        ;;
 edgecore,oap100)
index 515fa115d9c0edbaf681eee1570e05693a0a91cd..6997e19ffee22c5aeb0cf2737d40ef2c8c523d72 100755 (executable)
@@ -29,6 +29,7 @@ ipq40xx_setup_interfaces()
        engenius,eap1300|\
        engenius,emd1|\
        meraki,mr33|\
+       mikrotik,lhgg-60ad|\
        netgear,ex6100v2|\
        netgear,ex6150v2|\
        zyxel,wre6606)
@@ -176,6 +177,10 @@ ipq40xx_setup_macs()
                lan_mac=$(macaddr_add $wan_mac 1)
                label_mac="$wan_mac"
                ;;
+       mikrotik,lhgg-60ad)
+               lan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
+               label_mac="$lan_mac"
+               ;;
        esac
 
        [ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
index c94b4d8f9e0874ac75c4ad10c322faa50cf727aa..4a2a8e41db33bbdfac4c6a3d02d8f0abce690322 100644 (file)
@@ -111,7 +111,8 @@ platform_do_upgrade() {
                CI_KERNPART="part.safe"
                nand_do_upgrade "$1"
                ;;
-       mikrotik,hap-ac2)
+       mikrotik,hap-ac2 |\
+       mikrotik,lhgg-60ad)
                [ "$(rootfs_type)" = "tmpfs" ] && mtd erase firmware
                default_do_upgrade "$1"
                ;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-lhgg-60ad.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-lhgg-60ad.dts
new file mode 100644 (file)
index 0000000..158811c
--- /dev/null
@@ -0,0 +1,258 @@
+/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
+ * Copyright (c) 2019, Robert Marko <robimarko@gmail.com>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Mikrotik Wireless Wire Dish LHGG-60ad";
+       compatible = "mikrotik,lhgg-60ad";
+
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x10000000>;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       aliases {
+               led-boot = &user;
+               led-failsafe = &user;
+               led-running = &user;
+               led-upgrade = &user;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII_RGMII5>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       switch_mac_mode = <0x3>; /* mac mode for RGMII RMII */
+                       switch_lan_bmp = <0x0>; /* lan port bitmap */
+                       switch_wan_bmp = <0x10>; /* wan port bitmap */
+               };
+
+               edma@c080000 {
+                       qcom,single-phy;
+                       qcom,num_gmac = <1>;
+                       phy-mode = "rgmii-id";
+                       status = "okay";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "lhgg-60ad:blue:power";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "keep";
+                       panic-indicator;
+               };
+
+               user: user {
+                       label = "lhgg-60ad:yellow:user";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan {
+                       label = "lhgg-60ad:green:wlan";
+                       gpios = <&tlmm 58 GPIO_ACTIVE_HIGH>;
+               };
+
+               align-left {
+                       label = "lhgg-60ad:green:align-left";
+                       gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
+               };
+
+               align-right {
+                       label = "lhgg-60ad:green:align-right";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan-rx {
+                       label = "lhgg-60ad:green:align-down";
+                       gpios = <&tlmm 4 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan-tx {
+                       label = "lhgg-60ad:green:align-up";
+                       gpios = <&tlmm 5 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi-0-pinmux {
+               pinmux {
+                       function = "blsp_spi0";
+                       pins = "gpio13", "gpio14", "gpio15";
+                       bias-disable;
+               };
+
+               pinmux_cs {
+                       function = "gpio";
+                       pins = "gpio12";
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
+       status = "okay";
+
+       m25p80@0 {
+               reg = <0>;
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@0 {
+                               label = "RouterBoot";
+                               reg = <0x80000 0xe000>;
+                               read-only;
+                       };
+
+                       partition1@8e000 {
+                               label = "hard_config";
+                               reg = <0x8e000 0x01000>;
+                       };
+
+                       partition2@90000 {
+                               label = "dts_config";
+                               reg = <0x90000 0x10000>;
+                               read-only;
+                       };
+
+                       partition3@bd000 {
+                               label = "soft_config";
+                               reg = <0xbd000 0x01000>;
+                       };
+
+                       partition4@1000000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x100000 0xf00000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&pcie0 {
+       status = "okay";
+       perst-gpio = <&tlmm 42 GPIO_ACTIVE_HIGH>;
+
+       bridge@0,0 {
+               reg = <0x00000000 0 0 0 0>;
+               #address-cells = <3>;
+               #size-cells = <2>;
+               ranges;
+
+               /* wil6210 802.11ad card */
+               wifi: wifi@1,0 {
+                       status = "okay";
+                       /* wil6210 driver has no compatible */
+                       reg = <0x00010000 0 0 0 0>;
+               };
+       };
+};
+
+&gmac0 {
+       qcom,phy_mdio_addr = <0>;
+       qcom,poll_required = <1>;
+       vlan_tag = <0 0x20>;
+};
index 3d3c07643f68968ce7e51c3c9bd77040c7ea8da7..26e80771f7f9ba672cc56145e704fe0528d1f260 100644 (file)
@@ -16,3 +16,11 @@ define Device/mikrotik_hap-ac2
        DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += mikrotik_hap-ac2
+
+define Device/mikrotik_lhgg-60ad
+       $(call Device/MikrotikNOR)
+       DEVICE_MODEL := Wireless Wire Dish LHGG-60ad
+       DEVICE_DTS := qcom-ipq4019-lhgg-60ad
+       DEVICE_PACKAGES += -kmod-ath10k-ct -ath10k-firmware-qca4019-ct kmod-wil6210
+endef
+TARGET_DEVICES += mikrotik_lhgg-60ad
index 6a421b90079b12f904f534c53fd2ff0b8da8eb28..b79295a08bbb2906c08b566ba3ba3c4cc954198b 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,59 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -837,11 +837,60 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -51,6 +51,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4019-fritzrepeater-1200.dtb \
 +      qcom-ipq4019-fritzrepeater-3000.dtb \
 +      qcom-ipq4019-map-ac2200.dtb \
++      qcom-ipq4019-lhgg-60ad.dtb \
 +      qcom-ipq4019-mr8300.dtb \
 +      qcom-ipq4019-e2600ac-c1.dtb \
 +      qcom-ipq4019-e2600ac-c2.dtb \