iproute2: add missing libbpf dependency
authorKien Truong <duckientruong@gmail.com>
Sat, 10 Sep 2022 08:25:35 +0000 (15:25 +0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 2 Apr 2023 20:25:49 +0000 (22:25 +0200)
This patch adds libbpf to the dependencies of tc-mod-iptables.

The package tc-mod-iptables is missing libbpf as a dependency,
which leads to the build failure described in bug #9491

    LIBBPF_FORCE=on set, but couldn't find a usable libbpf

The build dependency is already automatically added because some other
packages from iproute2 depend on libbpf, but bpftools has multiple build
variants. With multiple build variants none gets build by default and
the build system will not build bpftools before iproute2.

Fixes: #9491
Signed-off-by: Kien Truong <duckientruong@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit fa468d4bcdc7e6eb84ea51d9b05368ed87c43aae)

package/network/utils/iproute2/Makefile

index afad0e79d671f141f6c875230bc0581c5236ea2e..939dfa9e8bc33d1dac1b46cb395fcdfc1bf000d3 100644 (file)
@@ -82,7 +82,7 @@ define Package/tc-mod-iptables
 $(call Package/iproute2/Default)
   TITLE:=Traffic control module - iptables action
   VARIANT:=tcfull
-  DEPENDS:=+libxtables
+  DEPENDS:=+libxtables +libbpf
 endef
 
 define Package/genl