generic: 5.15: refresh backport patches
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 16 Oct 2022 11:19:05 +0000 (13:19 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 16 Oct 2022 11:19:05 +0000 (13:19 +0200)
Refresh backport patches for kernel 5.15.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/generic/backport-5.15/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
target/linux/generic/backport-5.15/005-v5.17-02-Kbuild-move-to-std-gnu11.patch
target/linux/generic/backport-5.15/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch
target/linux/generic/backport-5.15/011-kbuild-export-SUBARCH.patch
target/linux/generic/backport-5.15/776-v6.1-01-net-dsa-qca8k-fix-inband-mgmt-for-big-endian-systems.patch
target/linux/generic/backport-5.15/776-v6.1-02-net-dsa-qca8k-fix-ethtool-autocast-mib-for-big-endia.patch

index 141a7a18c5c5e98d719823b13a7f53b9e088194a..ff4c6d7041fbef2380d55e9bc7d38fc2cfcd3000 100644 (file)
@@ -35,25 +35,21 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
  scripts/mod/modpost.c             | 4 +++-
  3 files changed, 6 insertions(+), 2 deletions(-)
 
-diff --git a/Makefile b/Makefile
-index b9e0b5c604af..cfe400032f96 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -416,7 +416,8 @@ HOSTCXX    = g++
+@@ -432,7 +432,8 @@ HOSTCXX    = g++
  endif
-
  export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
 -                            -O2 -fomit-frame-pointer -std=gnu89
 +                            -O2 -fomit-frame-pointer -std=gnu89 \
 +                            -Wdeclaration-after-statement
  export KBUILD_USERLDFLAGS :=
-
  KBUILD_HOSTCFLAGS   := $(KBUILD_USERCFLAGS) $(HOST_LFS_CFLAGS) $(HOSTCFLAGS)
-diff --git a/arch/arm64/kernel/vdso32/Makefile b/arch/arm64/kernel/vdso32/Makefile
-index abad38c576e1..33cd7ed3f94f 100644
 --- a/arch/arm64/kernel/vdso32/Makefile
 +++ b/arch/arm64/kernel/vdso32/Makefile
-@@ -76,6 +76,7 @@ VDSO_CFLAGS += -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
+@@ -76,6 +76,7 @@ VDSO_CFLAGS += -Wall -Wundef -Wstrict-pr
                 -fno-strict-aliasing -fno-common \
                 -Werror-implicit-function-declaration \
                 -Wno-format-security \
@@ -61,21 +57,17 @@ index abad38c576e1..33cd7ed3f94f 100644
                 -std=gnu89
  VDSO_CFLAGS  += -O2
  # Some useful compiler-dependent flags from top-level Makefile
-diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
-index 3c27a177b28b..d2b17ed27e6e 100644
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
-@@ -844,8 +844,10 @@ static int match(const char *sym, const char * const pat[])
+@@ -833,8 +833,10 @@ static int match(const char *sym, const
  {
-       const char *p;
-       while (*pat) {
+       const char *p;
+       while (*pat) {
 +              const char *endp;
 +
-               p = *pat++;
+               p = *pat++;
 -              const char *endp = p + strlen(p) - 1;
 +              endp = p + strlen(p) - 1;
-
-               /* "*foo*" */
-               if (*p == '*' && *endp == '*') {
---
-2.37.2
+               /* "*foo*" */
+               if (*p == '*' && *endp == '*') {
index 79bda0cd7e3ed040fa7037983b0ddb93132d02a8..d22eefb7733bac6781721c600df746e87d278892 100644 (file)
@@ -47,18 +47,14 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
  Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/Makefile b/Makefile
-index cfe400032f96..fe86758acaaa 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -498,7 +498,7 @@ KBUILD_CFLAGS   := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs \
-                  -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
-                  -Werror=implicit-function-declaration -Werror=implicit-int \
-                  -Werror=return-type -Wno-format-security \
+@@ -516,7 +516,7 @@ KBUILD_CFLAGS   := -Wall -Wundef -Werror
+                  -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
+                  -Werror=implicit-function-declaration -Werror=implicit-int \
+                  -Werror=return-type -Wno-format-security \
 -                 -std=gnu89
 +                 -std=gnu11
  KBUILD_CPPFLAGS := -D__KERNEL__
  KBUILD_AFLAGS_KERNEL :=
  KBUILD_CFLAGS_KERNEL :=
---
-2.37.2
index f60daa380095954fbc6b533afc13d211eaa3eaf6..198c9e671ab627c2176f2543d1779ae0cdcd84c4 100644 (file)
@@ -30,18 +30,14 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
  Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/Makefile b/Makefile
-index fe86758acaaa..e569fccfb009 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -416,7 +416,7 @@ HOSTCXX    = g++
+@@ -432,7 +432,7 @@ HOSTCXX    = g++
  endif
-
  export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
 -                            -O2 -fomit-frame-pointer -std=gnu89 \
 +                            -O2 -fomit-frame-pointer -std=gnu11 \
-                             -Wdeclaration-after-statement
+                             -Wdeclaration-after-statement
  export KBUILD_USERLDFLAGS :=
-
---
-2.37.2
index 56e30c11cf47141105ddb12fda54af69640da769..d378dabddabea63d6b4397cf424760838c8a2640 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -525,7 +525,7 @@ KBUILD_LDFLAGS_MODULE :=
+@@ -526,7 +526,7 @@ KBUILD_LDFLAGS_MODULE :=
  KBUILD_LDFLAGS :=
  CLANG_FLAGS :=
  
index e706874a6a9472d3a7a210394caed1fed6e09cd8..4f0d95f456106a2479528860e07a8e3f272c22f2 100644 (file)
@@ -22,11 +22,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  include/linux/dsa/tag_qca.h      |  6 +--
  2 files changed, 50 insertions(+), 19 deletions(-)
 
-diff --git a/drivers/net/dsa/qca/qca8k-8xxx.c b/drivers/net/dsa/qca/qca8k-8xxx.c
-index 5669c92c93f7..644338ca0510 100644
 --- a/drivers/net/dsa/qca/qca8k-8xxx.c
 +++ b/drivers/net/dsa/qca/qca8k-8xxx.c
-@@ -137,27 +137,42 @@ static void qca8k_rw_reg_ack_handler(struct dsa_switch *ds, struct sk_buff *skb)
+@@ -137,27 +137,42 @@ static void qca8k_rw_reg_ack_handler(str
        struct qca8k_mgmt_eth_data *mgmt_eth_data;
        struct qca8k_priv *priv = ds->priv;
        struct qca_mgmt_ethhdr *mgmt_ethhdr;
@@ -76,7 +74,7 @@ index 5669c92c93f7..644338ca0510 100644
        }
  
        complete(&mgmt_eth_data->rw_done);
-@@ -169,8 +184,10 @@ static struct sk_buff *qca8k_alloc_mdio_header(enum mdio_cmd cmd, u32 reg, u32 *
+@@ -169,8 +184,10 @@ static struct sk_buff *qca8k_alloc_mdio_
        struct qca_mgmt_ethhdr *mgmt_ethhdr;
        unsigned int real_len;
        struct sk_buff *skb;
@@ -88,7 +86,7 @@ index 5669c92c93f7..644338ca0510 100644
  
        skb = dev_alloc_skb(QCA_HDR_MGMT_PKT_LEN);
        if (!skb)
-@@ -199,20 +216,32 @@ static struct sk_buff *qca8k_alloc_mdio_header(enum mdio_cmd cmd, u32 reg, u32 *
+@@ -199,20 +216,32 @@ static struct sk_buff *qca8k_alloc_mdio_
        hdr |= FIELD_PREP(QCA_HDR_XMIT_DP_BIT, BIT(0));
        hdr |= FIELD_PREP(QCA_HDR_XMIT_CONTROL, QCA_HDR_XMIT_TYPE_RW_REG);
  
@@ -128,7 +126,7 @@ index 5669c92c93f7..644338ca0510 100644
  
        return skb;
  }
-@@ -220,9 +249,11 @@ static struct sk_buff *qca8k_alloc_mdio_header(enum mdio_cmd cmd, u32 reg, u32 *
+@@ -220,9 +249,11 @@ static struct sk_buff *qca8k_alloc_mdio_
  static void qca8k_mdio_header_fill_seq_num(struct sk_buff *skb, u32 seq_num)
  {
        struct qca_mgmt_ethhdr *mgmt_ethhdr;
@@ -141,11 +139,9 @@ index 5669c92c93f7..644338ca0510 100644
  }
  
  static int qca8k_read_eth(struct qca8k_priv *priv, u32 reg, u32 *val, int len)
-diff --git a/include/linux/dsa/tag_qca.h b/include/linux/dsa/tag_qca.h
-index 50be7cbd93a5..0e176da1e43f 100644
 --- a/include/linux/dsa/tag_qca.h
 +++ b/include/linux/dsa/tag_qca.h
-@@ -61,9 +61,9 @@ struct sk_buff;
+@@ -56,9 +56,9 @@
  
  /* Special struct emulating a Ethernet header */
  struct qca_mgmt_ethhdr {
@@ -158,6 +154,3 @@ index 50be7cbd93a5..0e176da1e43f 100644
        __be16 hdr;             /* qca hdr */
  } __packed;
  
--- 
-2.37.2
-
index 93c0bb85b5bc955e1e31d6881070005adf94fac7..d13014bf93bdf90f7ca055d02b5ff57e018c3159 100644 (file)
@@ -19,11 +19,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  include/linux/dsa/tag_qca.h      |  2 +-
  2 files changed, 9 insertions(+), 13 deletions(-)
 
-diff --git a/drivers/net/dsa/qca/qca8k-8xxx.c b/drivers/net/dsa/qca/qca8k-8xxx.c
-index 644338ca0510..c5c3b4e92f28 100644
 --- a/drivers/net/dsa/qca/qca8k-8xxx.c
 +++ b/drivers/net/dsa/qca/qca8k-8xxx.c
-@@ -1518,9 +1518,9 @@ static void qca8k_mib_autocast_handler(struct dsa_switch *ds, struct sk_buff *sk
+@@ -1668,9 +1668,9 @@ static void qca8k_mib_autocast_handler(s
        struct qca8k_priv *priv = ds->priv;
        const struct qca8k_mib_desc *mib;
        struct mib_ethhdr *mib_ethhdr;
@@ -35,7 +33,7 @@ index 644338ca0510..c5c3b4e92f28 100644
  
        mib_ethhdr = (struct mib_ethhdr *)skb_mac_header(skb);
        mib_eth_data = &priv->mib_eth_data;
-@@ -1532,28 +1532,24 @@ static void qca8k_mib_autocast_handler(struct dsa_switch *ds, struct sk_buff *sk
+@@ -1682,28 +1682,24 @@ static void qca8k_mib_autocast_handler(s
        if (port != mib_eth_data->req_port)
                goto exit;
  
@@ -70,11 +68,9 @@ index 644338ca0510..c5c3b4e92f28 100644
        }
  
  exit:
-diff --git a/include/linux/dsa/tag_qca.h b/include/linux/dsa/tag_qca.h
-index 0e176da1e43f..b1b5720d89a5 100644
 --- a/include/linux/dsa/tag_qca.h
 +++ b/include/linux/dsa/tag_qca.h
-@@ -73,7 +73,7 @@ enum mdio_cmd {
+@@ -68,7 +68,7 @@ enum mdio_cmd {
  };
  
  struct mib_ethhdr {
@@ -83,6 +79,3 @@ index 0e176da1e43f..b1b5720d89a5 100644
        __be16 hdr;             /* qca hdr */
  } __packed;
  
--- 
-2.37.2
-