kernel: bump 4.14 to 4.14.79
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 5 Nov 2018 10:23:17 +0000 (11:23 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 5 Nov 2018 15:00:47 +0000 (16:00 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6, x86_64
Runtime-tested on: cns3xxx, imx6, x86_64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
30 files changed:
include/kernel-version.mk
target/linux/ath25/patches-4.14/107-ar5312_gpio.patch
target/linux/bcm53xx/patches-4.14/400-mtd-spi-nor-detect-JEDEC-incompatible-w25q128-using-.patch
target/linux/brcm63xx/patches-4.14/001-4.15-01-MIPS-BCM63XX-add-clkdev-lookup-support.patch
target/linux/brcm63xx/patches-4.14/322-MIPS-BCM63XX-switch-to-IRQ_DOMAIN.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/301-mips_image_cmdline_hack.patch
target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
target/linux/generic/pending-4.14/201-extra_optimization.patch
target/linux/generic/pending-4.14/300-mips_expose_boot_raw.patch
target/linux/generic/pending-4.14/304-mips_disable_fpu.patch
target/linux/generic/pending-4.14/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch
target/linux/generic/pending-4.14/450-mtd-spi-nor-allow-NOR-driver-to-write-fewer-bytes-th.patch
target/linux/generic/pending-4.14/465-m25p80-mx-disable-software-protection.patch
target/linux/generic/pending-4.14/466-Revert-mtd-spi-nor-fix-Spansion-regressions-aliased-.patch
target/linux/generic/pending-4.14/470-mtd-spi-nor-support-limiting-4K-sectors-support-base.patch
target/linux/generic/pending-4.14/477-mtd-add-spi-nor-add-mx25u3235f.patch
target/linux/generic/pending-4.14/478-mtd-spi-nor-Add-support-for-XM25QH64A-and-XM25QH128A.patch
target/linux/generic/pending-4.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/pending-4.14/701-phy_extension.patch
target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
target/linux/ipq806x/patches-4.14/105-mtd-nor-add-mx25l25635f.patch
target/linux/lantiq/patches-4.14/0152-lantiq-VPE.patch
target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
target/linux/pistachio/patches-4.14/401-mtd-nor-support-mtd-name-from-device-tree.patch
target/linux/ramips/patches-4.14/0025-pinctrl-ralink-add-pinctrl-driver.patch
target/linux/ramips/patches-4.14/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch
target/linux/ramips/patches-4.14/0053-mtd-spi-nor-add-w25q256-3b-mode-switch.patch
target/linux/ramips/patches-4.14/303-spi-nor-enable-4B-opcodes-for-mx66l51235l.patch

index f0ac2671ed134891339d560f88a67ea4cd69f23e..320ecd5ce63a24e4a41993c78725a9ad5b61158f 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .135
-LINUX_VERSION-4.14 = .78
+LINUX_VERSION-4.14 = .79
 
 LINUX_KERNEL_HASH-4.9.135 = e023b0bbe9ea7fc56aa57210342dd18ea3e0900ee207226df1523c6d7df154ce
-LINUX_KERNEL_HASH-4.14.78 = f4da4dc0f079e420e1c1b8c71312eaa5415b08be847aa224a61d8af6a6e74c6c
+LINUX_KERNEL_HASH-4.14.79 = 5619071eceb27f903d2fce1784223796bfbe25528f9690273cdfe82fdd9b933a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 9b2bee1d7378723ed772e57ead43c3f9a7b9450f..e74e20b05a4e11de28a129a757166acdefa6047f 100644 (file)
 +subsys_initcall(ar5312_gpio_init);
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -174,6 +174,7 @@ config ATH25
+@@ -175,6 +175,7 @@ config ATH25
        select CEVT_R4K
        select CSRC_R4K
        select DMA_NONCOHERENT
index 8eb70b4e53e4c83cf914c3f702ad18f6f8b534ad..58cd1bf84daecc206b0ad4fa08bce135c4724555 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1209,6 +1209,18 @@ static const struct flash_info *spi_nor_
+@@ -1215,6 +1215,18 @@ static const struct flash_info *spi_nor_
        }
        dev_err(nor->dev, "unrecognized JEDEC id bytes: %02x, %02x, %02x\n",
                id[0], id[1], id[2]);
index 68f64d17bfc03757ab41a349b70c8dc37cf64f9e..b6d755d29bc340b27a3ea9b0e1c0528a1b13a0c3 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -278,6 +278,7 @@ config BCM63XX
+@@ -279,6 +279,7 @@ config BCM63XX
        select GPIOLIB
        select HAVE_CLK
        select MIPS_L1_CACHE_SHIFT_4
index 0e44117a3500b5b29ee06e83609d126ee7d6b45a..d04d89cf62412f42ab1369aedf2589c7fe1414e7 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -271,6 +271,9 @@ config BCM63XX
+@@ -272,6 +272,9 @@ config BCM63XX
        select SYNC_R4K
        select DMA_NONCOHERENT
        select IRQ_MIPS_CPU
index 79fdb6e8014fa0a8cbe6d6411eac26d4648411ff..fd53dbd40d6ade8921bd29651391360fe926d8c7 100644 (file)
@@ -171,7 +171,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
        .init.data : {
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -39,6 +39,7 @@ config MIPS
+@@ -40,6 +40,7 @@ config MIPS
        select HAVE_CBPF_JIT if (!64BIT && !CPU_MICROMIPS)
        select HAVE_EBPF_JIT if (64BIT && !CPU_MICROMIPS)
        select HAVE_CC_STACKPROTECTOR
index 01caff5b89e87849282b3224d197f6cc692ff03d..eb6011e813da60183877379b5c08c622c5cf5fa6 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1157,6 +1157,10 @@ config SYNC_R4K
+@@ -1158,6 +1158,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index d1e92ae40af4cb12a66a4d063833396ddf2b374e..8007e28301e8cabb4c93cbe32cf5c899543fb307 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2028,7 +2028,7 @@ static int __init pktsched_init(void)
+@@ -2029,7 +2029,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index 3c3353c7d16e147a462eed0194e3fac031f99fd7..42cd7f158528df923e6eaffc5a3c0cf000c952c6 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -650,12 +650,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+@@ -652,12 +652,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
  KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
index 9419e9916bbb6c83cff23b30e8a7fd55014ce02a..5384be15ca02e4c77c2f762d00626c2454b8d613 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1066,9 +1066,6 @@ config FW_ARC
+@@ -1067,9 +1067,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2966,6 +2963,18 @@ choice
+@@ -2967,6 +2964,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index 1cfd3d7d7a9b0ef330d5f9bd0167fb578dbbf714..22e2e86206c191275c38ccba6dd922a1f75779aa 100644 (file)
@@ -24,7 +24,7 @@ v2: incorporated changes suggested by Jonas Gorski
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2890,6 +2890,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2891,6 +2891,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index 3cd87861a4e1ba0886c0b7d7ff210dc25b8cebdb..de2dd65b1795c7f74021fe5eac61363d51755ec5 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -220,6 +220,7 @@ config BMIPS_GENERIC
+@@ -221,6 +221,7 @@ config BMIPS_GENERIC
        select BRCMSTB_L2_IRQ
        select IRQ_MIPS_CPU
        select DMA_NONCOHERENT
@@ -22,7 +22,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        select SYS_SUPPORTS_32BIT_KERNEL
        select SYS_SUPPORTS_LITTLE_ENDIAN
        select SYS_SUPPORTS_BIG_ENDIAN
-@@ -345,6 +346,7 @@ config MACH_JAZZ
+@@ -346,6 +347,7 @@ config MACH_JAZZ
        select CSRC_R4K
        select DEFAULT_SGI_PARTITION if CPU_BIG_ENDIAN
        select GENERIC_ISA_DMA
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        select HAVE_PCSPKR_PLATFORM
        select IRQ_MIPS_CPU
        select I8253
-@@ -1127,6 +1129,9 @@ config DMA_NONCOHERENT
+@@ -1128,6 +1130,9 @@ config DMA_NONCOHERENT
        bool
        select NEED_DMA_MAP_STATE
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config NEED_DMA_MAP_STATE
        bool
  
-@@ -1651,6 +1656,7 @@ config CPU_R10000
+@@ -1652,6 +1657,7 @@ config CPU_R10000
        select CPU_SUPPORTS_64BIT_KERNEL
        select CPU_SUPPORTS_HIGHMEM
        select CPU_SUPPORTS_HUGEPAGES
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
          MIPS Technologies R10000-series processors.
  
-@@ -1899,9 +1905,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
+@@ -1900,9 +1906,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
        bool
  
  config SYS_HAS_CPU_MIPS32_R5
@@ -60,7 +60,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        bool
  
  config SYS_HAS_CPU_MIPS64_R1
-@@ -1911,6 +1919,7 @@ config SYS_HAS_CPU_MIPS64_R2
+@@ -1912,6 +1920,7 @@ config SYS_HAS_CPU_MIPS64_R2
        bool
  
  config SYS_HAS_CPU_MIPS64_R6
index 50ed2be3d776aa53dcd23e270f03b5737ff8bfd4..571c9b885f3e6cb5ee4361a420071f1fb5c49a1a 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1371,7 +1371,7 @@ static int spi_nor_write(struct mtd_info
+@@ -1377,7 +1377,7 @@ static int spi_nor_write(struct mtd_info
  
                write_enable(nor);
                ret = nor->write(nor, addr, page_remain, buf + i);
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                        goto write_err;
                written = ret;
  
-@@ -1380,13 +1380,6 @@ static int spi_nor_write(struct mtd_info
+@@ -1386,13 +1386,6 @@ static int spi_nor_write(struct mtd_info
                        goto write_err;
                *retlen += written;
                i += written;
index dc71e9d5427dd90a98cd2ec8f340db39c11d3019..b41710276fff4049d9cd910b784e7c69d1c14f47 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2708,6 +2708,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2714,6 +2714,7 @@ int spi_nor_scan(struct spi_nor *nor, co
  
        if (JEDEC_MFR(info) == SNOR_MFR_ATMEL ||
            JEDEC_MFR(info) == SNOR_MFR_INTEL ||
index fc5cf6232400e6c685054ed69969e697d81318da..55d9709761c7c6d3e2bb722256db9e3f18871f17 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2710,6 +2710,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2716,6 +2716,7 @@ int spi_nor_scan(struct spi_nor *nor, co
            JEDEC_MFR(info) == SNOR_MFR_INTEL ||
            JEDEC_MFR(info) == SNOR_MFR_MACRONIX ||
            JEDEC_MFR(info) == SNOR_MFR_SST ||
@@ -25,7 +25,7 @@ Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
            info->flags & SPI_NOR_HAS_LOCK) {
                write_enable(nor);
                write_sr(nor, 0);
-@@ -2728,7 +2729,8 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2734,7 +2735,8 @@ int spi_nor_scan(struct spi_nor *nor, co
  
        /* NOR protection support for STmicro/Micron chips and similar */
        if (JEDEC_MFR(info) == SNOR_MFR_MICRON ||
index 88775041ce89c4b259d47805d81cd0064bfc2d99..231f9c21a4e2394a6db5f6514274cc1cdab9648d 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        depends on ARCH_AT91 || (ARM && COMPILE_TEST)
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2555,10 +2555,12 @@ static int spi_nor_select_erase(struct s
+@@ -2561,10 +2561,12 @@ static int spi_nor_select_erase(struct s
  
  #ifdef CONFIG_MTD_SPI_NOR_USE_4K_SECTORS
        /* prefer "small sector" erase if possible */
index 191e01df7a50a85bd13e237684a58be45260ee24..2d94959c5c0f22edd90696b87bd19623be9baa90 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: André Valentin <avalentin@marcant.net>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1016,6 +1016,7 @@ static const struct flash_info spi_nor_i
+@@ -1022,6 +1022,7 @@ static const struct flash_info spi_nor_i
        { "mx25l3205d",  INFO(0xc22016, 0, 64 * 1024,  64, SECT_4K) },
        { "mx25l3255e",  INFO(0xc29e16, 0, 64 * 1024,  64, SECT_4K) },
        { "mx25l6405d",  INFO(0xc22017, 0, 64 * 1024, 128, SECT_4K) },
index b7361d2ab5080acb805bed6dfee15eb5efce6fcd..b7c4f23a14932887ac845d72d2d4edff4a27a082 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1181,6 +1181,10 @@ static const struct flash_info spi_nor_i
+@@ -1187,6 +1187,10 @@ static const struct flash_info spi_nor_i
        { "3S400AN", S3AN_INFO(0x1f2400, 256, 264) },
        { "3S700AN", S3AN_INFO(0x1f2500, 512, 264) },
        { "3S1400AN", S3AN_INFO(0x1f2600, 512, 528) },
index 0b46ed9e47b8009ab12d2e77ffddb8c995f6d5e2..7c60d7e79998db95d2161048af65bceb225b9990 100644 (file)
@@ -300,7 +300,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
-@@ -1304,6 +1444,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1305,6 +1445,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  {
        struct ip6_tnl *t = netdev_priv(dev);
        struct ipv6hdr *ipv6h;
@@ -308,7 +308,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        int encap_limit = -1;
        __u16 offset;
        struct flowi6 fl6;
-@@ -1370,6 +1511,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1371,6 +1512,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  
        fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
  
@@ -327,7 +327,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (iptunnel_handle_offloads(skb, SKB_GSO_IPXIP6))
                return -1;
  
-@@ -1498,6 +1651,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1499,6 +1652,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.link = p->link;
        t->parms.proto = p->proto;
        t->parms.fwmark = p->fwmark;
@@ -342,7 +342,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        dst_cache_reset(&t->dst_cache);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1536,6 +1697,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1537,6 +1698,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -350,7 +350,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1922,6 +2084,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1923,6 +2085,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -366,7 +366,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1959,6 +2130,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1960,6 +2131,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_FWMARK])
                parms->fwmark = nla_get_u32(data[IFLA_IPTUN_FWMARK]);
@@ -413,7 +413,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static bool ip6_tnl_netlink_encap_parms(struct nlattr *data[],
-@@ -2074,6 +2285,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -2075,6 +2286,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -426,7 +426,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -2103,6 +2320,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -2104,6 +2321,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(0) +
                /* IFLA_IPTUN_FWMARK */
                nla_total_size(4) +
@@ -451,7 +451,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -2110,6 +2345,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2111,6 +2346,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -461,7 +461,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -2119,9 +2357,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2120,9 +2358,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
            nla_put_u8(skb, IFLA_IPTUN_PROTO, parm->proto) ||
@@ -490,7 +490,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (nla_put_u16(skb, IFLA_IPTUN_ENCAP_TYPE, tunnel->encap.type) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_SPORT, tunnel->encap.sport) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_DPORT, tunnel->encap.dport) ||
-@@ -2161,6 +2417,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -2162,6 +2418,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_ENCAP_DPORT]        = { .type = NLA_U16 },
        [IFLA_IPTUN_COLLECT_METADATA]   = { .type = NLA_FLAG },
        [IFLA_IPTUN_FWMARK]             = { .type = NLA_U32 },
index 1b380e24a9aa437534560442bde18467ba98f384..0f0b0e046777d7ccc0b7d9cbf3a59179724c4acd 100644 (file)
@@ -85,7 +85,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
   * @phydev: the phy_device struct
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -905,6 +905,7 @@ void phy_ethtool_ksettings_get(struct ph
+@@ -909,6 +909,7 @@ void phy_ethtool_ksettings_get(struct ph
                               struct ethtool_link_ksettings *cmd);
  int phy_ethtool_ksettings_set(struct phy_device *phydev,
                              const struct ethtool_link_ksettings *cmd);
index 4ee79515c9a8dac1c635d7e57565ec5edea6e8ef..9fa8a91e06fe43b85944737ede5a0288fa4fcb19 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1184,6 +1184,9 @@ static void __init ubi_auto_attach(void)
+@@ -1183,6 +1183,9 @@ static void __init ubi_auto_attach(void)
        mtd = open_mtd_device("ubi");
        if (IS_ERR(mtd))
                mtd = open_mtd_device("data");
index 24a7fda22359d44ae908883cefaded6972583cdd..eee2b4c5ec999b7515811146bf4228a60b1bd497 100644 (file)
@@ -11,7 +11,7 @@ the ubi volume created by the other.
 ---
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1023,7 +1023,7 @@ static const struct flash_info spi_nor_i
+@@ -1029,7 +1029,7 @@ static const struct flash_info spi_nor_i
        { "mx25u6435f",  INFO(0xc22537, 0, 64 * 1024, 128, SECT_4K) },
        { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
        { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
index c0639e137f88d3c52f2c111b33d250489ecc18f3..fc4e414df5aea1bb57c2e810bd9a0491c8a4aae2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2323,6 +2323,12 @@ config MIPS_VPE_LOADER
+@@ -2324,6 +2324,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 134d95d99261cfcec00b33a3aa3b21674275c06e..c396e314a9f1e1ba9637dcf7aaf2c4d74c704022 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1926,7 +1926,7 @@ static struct phy_driver genphy_driver =
+@@ -1943,7 +1943,7 @@ static struct phy_driver genphy_driver =
        .config_init    = genphy_config_init,
        .features       = PHY_GBIT_FEATURES | SUPPORTED_MII |
                          SUPPORTED_AUI | SUPPORTED_FIBRE |
index eeb1e4dee88e5cfae7affa18b6b6175ba0aeb1f0..47b6b177696cbcb41b7d2951a1ed798f5745b76f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2650,6 +2650,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2656,6 +2656,7 @@ int spi_nor_scan(struct spi_nor *nor, co
        struct device *dev = nor->dev;
        struct mtd_info *mtd = &nor->mtd;
        struct device_node *np = spi_nor_get_flash_node(nor);
@@ -18,7 +18,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
        int ret;
        int i;
  
-@@ -2725,7 +2726,12 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2731,7 +2732,12 @@ int spi_nor_scan(struct spi_nor *nor, co
                spi_nor_wait_till_ready(nor);
        }
  
index 3e5dac5376524b2df16d64881e515001dab4c010..dd44a64bfdada11aecbc85523a7bd35cc459e9c1 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -628,6 +628,8 @@ config RALINK
+@@ -629,6 +629,8 @@ config RALINK
        select CLKDEV_LOOKUP
        select ARCH_HAS_RESET_CONTROLLER
        select RESET_CONTROLLER
index d657274efe49859e0abe69c17d8dd9858c068724..debeae28060a2e1a59931124efad21bc355fe445 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -630,6 +630,9 @@ config RALINK
+@@ -631,6 +631,9 @@ config RALINK
        select RESET_CONTROLLER
        select PINCTRL
        select PINCTRL_RT2880
index 85a5c1310c1a388ffe67d032d552419e6b857153..19bac1f64ff6fb22b84888db3dca39f81b356dd1 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/media/usb/uvc/uvc_driver.c
 +++ b/drivers/media/usb/uvc/uvc_driver.c
-@@ -2734,6 +2734,18 @@ static const struct usb_device_id uvc_id
+@@ -2727,6 +2727,18 @@ static const struct usb_device_id uvc_id
          .bInterfaceSubClass   = 1,
          .bInterfaceProtocol   = 0,
          .driver_info          = UVC_QUIRK_FORCE_Y8 },
index 2e7cc33c8f6a79526aa50d03b8cc23485a8b7e61..e7161af9595bac98e233f482481cd47b5a9b2aeb 100644 (file)
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_LOCK);
        return ret;
-@@ -1164,7 +1216,7 @@ static const struct flash_info spi_nor_i
+@@ -1170,7 +1222,7 @@ static const struct flash_info spi_nor_i
        { "w25q80", INFO(0xef5014, 0, 64 * 1024,  16, SECT_4K) },
        { "w25q80bl", INFO(0xef4014, 0, 64 * 1024,  16, SECT_4K) },
        { "w25q128", INFO(0xef4018, 0, 64 * 1024, 256, SECT_4K) },
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        { "w25m512jv", INFO(0xef7119, 0, 64 * 1024, 1024,
                        SECT_4K | SPI_NOR_QUAD_READ | SPI_NOR_DUAL_READ) },
  
-@@ -1224,6 +1276,9 @@ static int spi_nor_read(struct mtd_info
+@@ -1230,6 +1282,9 @@ static int spi_nor_read(struct mtd_info
        if (ret)
                return ret;
  
@@ -135,7 +135,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        while (len) {
                loff_t addr = from;
  
-@@ -1248,6 +1303,18 @@ static int spi_nor_read(struct mtd_info
+@@ -1254,6 +1309,18 @@ static int spi_nor_read(struct mtd_info
        ret = 0;
  
  read_err:
@@ -154,7 +154,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_READ);
        return ret;
  }
-@@ -1349,6 +1416,10 @@ static int spi_nor_write(struct mtd_info
+@@ -1355,6 +1422,10 @@ static int spi_nor_write(struct mtd_info
        if (ret)
                return ret;
  
@@ -165,7 +165,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        for (i = 0; i < len; ) {
                ssize_t written;
                loff_t addr = to + i;
-@@ -1389,6 +1460,7 @@ static int spi_nor_write(struct mtd_info
+@@ -1395,6 +1466,7 @@ static int spi_nor_write(struct mtd_info
        }
  
  write_err:
@@ -173,7 +173,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_WRITE);
        return ret;
  }
-@@ -2805,8 +2877,10 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2811,8 +2883,10 @@ int spi_nor_scan(struct spi_nor *nor, co
        } else if (mtd->size > 0x1000000) {
                /* enable 4-byte addressing if the device exceeds 16MiB */
                nor->addr_width = 4;
index ea8d83d98e1355faf12ee13154b95ce89e6c61ff..d959ddb097f5d2c35b0d0c55b02abd0a990fc82e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1083,7 +1083,7 @@ static const struct flash_info spi_nor_i
+@@ -1089,7 +1089,7 @@ static const struct flash_info spi_nor_i
        { "mx25l25635e", INFO(0xc22019, 0, 64 * 1024, 512, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
        { "mx25u25635f", INFO(0xc22539, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_4B_OPCODES) },
        { "mx25l25655e", INFO(0xc22619, 0, 64 * 1024, 512, 0) },