tools/fakeroot: update to 1.29
authorNick Hainke <vincent@systemli.org>
Mon, 29 Aug 2022 05:55:14 +0000 (07:55 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 7 Sep 2022 03:22:40 +0000 (04:22 +0100)
Release Notes:
https://salsa.debian.org/clint/fakeroot/-/commit/8dd9e34a2e54862a902040d76adbd1c1a42ffc35

Refresh patches:
- 400-alpine-libc.musl-fix.patch
- 600-macOS.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/fakeroot/Makefile
tools/fakeroot/patches/400-alpine-libc.musl-fix.patch
tools/fakeroot/patches/600-macOS.patch

index c29f51e77f5e23215d648d198e959622e4b24c00..5d31e197819f1fd52778c902e1a4ecab89362762 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fakeroot
-PKG_VERSION:=1.28
+PKG_VERSION:=1.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=@DEBIAN/pool/main/f/fakeroot
-PKG_HASH:=56d405e36ff685f83879be08fdd654255ab9aa38632b4605a98e896ad63990c2
+PKG_HASH:=8fbbafb780c9173e3ace4a04afbc1d900f337f3216883939f5c7db3431be7c20
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_FIXUP:=autoreconf
index 530c96842efbad1f7d4ddb3d190fcded9186c242..f740b120a14eac8f61fa77d2f5eab856a9f0cbee 100644 (file)
@@ -21,7 +21,7 @@ Error relocating openwrt/staging_dir/host/lib/libfakeroot.so: SEND_GET_XATTR: sy
  #define SEND_GET_XATTR64(a,b,c) send_get_xattr64(a,b)
  #endif
  
-@@ -140,8 +142,9 @@
+@@ -142,8 +144,9 @@
  
  /* 10.10 uses id_t in getpriority/setpriority calls, so pretend
     id_t is used everywhere, just happens to be int on some OSes */
index f9d6d189b25a64829bd0716f3cb6809907ab3a70..730367f07c7fadbd2f8fb66213cf36473da18535 100644 (file)
@@ -36,7 +36,7 @@
  posix_spawn;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  posix_spawnp;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  #endif
-@@ -232,7 +234,7 @@ facl;int;(int fd, int cmd, int cnt, void
+@@ -229,7 +231,7 @@ facl;int;(int fd, int cmd, int cnt, void
  #ifdef HAVE_FTS_READ
  fts_read;FTSENT *;(FTS *ftsp);(ftsp)
  #ifdef __APPLE__
@@ -45,7 +45,7 @@
  fts_read$INODE64;FTSENT *;(FTS *ftsp);(ftsp)
  #endif
  #endif /* ifdef __APPLE__ */
-@@ -240,7 +242,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
+@@ -237,7 +239,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
  #ifdef HAVE_FTS_CHILDREN
  fts_children;FTSENT *;(FTS *ftsp, int options);(ftsp, options)
  #ifdef __APPLE__