mediatek: make GL-MT2500 image work with U-Boot recovery
authorDavid Bauer <mail@david-bauer.net>
Tue, 28 Nov 2023 00:03:48 +0000 (01:03 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sun, 3 Dec 2023 05:50:52 +0000 (06:50 +0100)
Append metadata in the special GL.iNet format.
This also enables use of the web-based U-Boot recovery.

U-Boot-Recovery
===============

The GL-MT2500 provides web-based U-Boot recovery. For this, hold the
reset button pressed for 5 seconds when attaching power to the device.

The LED will blink 5 times. Release the reset button.

The OpenWrt sysupgrade image can be installed by navigating to
http://192.168.1.1 in a web-browser.

The device does not work as a DHCP server, so manual IP configuration is
required.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mediatek/image/filogic.mk

index 1a1c813eeaccd4ce61dad9f5a88a2a57c25e93be..edee317fdf33c5db4b175264ec3624c9bee92805 100644 (file)
@@ -299,7 +299,7 @@ define Device/glinet_gl-mt2500
   DEVICE_PACKAGES := e2fsprogs f2fsck mkf2fs kmod-usb3
   SUPPORTED_DEVICES += glinet,mt2500-emmc
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-gl-metadata
 endef
 TARGET_DEVICES += glinet_gl-mt2500