kernel: bump 4.14 to 4.14.87
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 Dec 2018 14:45:27 +0000 (15:45 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 10 Dec 2018 15:32:22 +0000 (16:32 +0100)
Refreshed all patches.

Remove upstreamed:
- 0008-MIPS-ralink-Fix-mt7620-nd_sd-pinmux.patch

Compile-tested: cns3xxx, imx6
Runtime-tested: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/207-disable-modorder.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/ramips/patches-4.14/0008-MIPS-ralink-Fix-mt7620-nd_sd-pinmux.patch [deleted file]

index aba634f3bfef225ed6b08373213c040f0177590e..b36287651e0ca1ab4f4a88f4691ae188c3225f44 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .128
 LINUX_VERSION-4.9 = .144
-LINUX_VERSION-4.14 = .86
+LINUX_VERSION-4.14 = .87
 
 LINUX_KERNEL_HASH-3.18.128 = 396368ef7eadf639c6f62ef43ea9c63a05280f926f731c3a86b0aa0e2b3ad2e3
 LINUX_KERNEL_HASH-4.9.144 = 05d17f434d22e9fa2f9084cdf6858383564883d23a1d11ce4dae4b217662782b
-LINUX_KERNEL_HASH-4.14.86 = da9260a9022b917733201b89b5314847cb3332c31e70acb5e9b547956c266e28
+LINUX_KERNEL_HASH-4.14.87 = 36744d7d657dab23e455a8096e4ad2dc6a25f25fdce062d8a8bdf4499112e125
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index fe6d5212f26d6f8ac7158db0f1f97df5634a9132..0619dcaa7bfc627226232d831b91c5488299cdea 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1234,7 +1234,6 @@ all: modules
+@@ -1237,7 +1237,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1263,7 +1262,6 @@ _modinst_:
+@@ -1266,7 +1265,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index 4e700ca0b72c138754c8ced83572b601147856e3..cae6d66e7df4c64eceeb04122f5cd9b8b0abc74f 100644 (file)
@@ -243,7 +243,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1951,10 +1951,12 @@ void __init init_mm_internals(void)
+@@ -1955,10 +1955,12 @@ void __init init_mm_internals(void)
        start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS
diff --git a/target/linux/ramips/patches-4.14/0008-MIPS-ralink-Fix-mt7620-nd_sd-pinmux.patch b/target/linux/ramips/patches-4.14/0008-MIPS-ralink-Fix-mt7620-nd_sd-pinmux.patch
deleted file mode 100644 (file)
index acfda58..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From d41237229464ae03fe116b591e8a2fda4ffea48e Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Sun, 28 Oct 2018 12:46:55 +0100
-Subject: [PATCH] MIPS: ralink: Fix mt7620 nd_sd pinmux
-
-In case the nd_sd group is set to the sd-card function, Pins 45 + 46 are
-configured as GPIOs. If they are blocked by the sd function, they can't
-be used as GPIOs.
-
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Reported-by: Kristian Evensen <kristian.evensen@gmail.com>
-Fixes: f576fb6a0700 ("MIPS: ralink: cleanup the soc specific pinmux
-data")
-Cc: stable@vger.kernel.org # v3.18+
----
- arch/mips/ralink/mt7620.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -84,7 +84,7 @@ static struct rt2880_pmx_func pcie_rst_g
- };
- static struct rt2880_pmx_func nd_sd_grp[] = {
-       FUNC("nand", MT7620_GPIO_MODE_NAND, 45, 15),
--      FUNC("sd", MT7620_GPIO_MODE_SD, 45, 15)
-+      FUNC("sd", MT7620_GPIO_MODE_SD, 47, 13)
- };
- static struct rt2880_pmx_group mt7620a_pinmux_data[] = {