fix a small logic error in package download
authorFelix Fietkau <nbd@openwrt.org>
Sun, 9 Oct 2011 16:54:03 +0000 (16:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 9 Oct 2011 16:54:03 +0000 (16:54 +0000)
SVN-Revision: 28395

include/package.mk

index 2ad0f11bc840259c92cd6c67f0e71cacea8df9f3..c0c91946d487a0fc9f994a03eaf45c0f9b9372c9 100644 (file)
@@ -109,7 +109,7 @@ Build/Exports=$(Build/Exports/Default)
 
 define Build/DefaultTargets
   $(if $(QUILT),$(Build/Quilt))
-  $(if $(USE_GIT_TREE),$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+  $(if $(USE_GIT_TREE),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(call Build/Autoclean)
 
   download: