ath79: DO NOT MERGE: add a custom WR741N v1/v2 8Mb variant
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 12 Aug 2023 21:57:31 +0000 (23:57 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 24 Oct 2023 21:23:21 +0000 (23:23 +0200)
Device is a WR741N v2.4 (AR7240) with the flash replaced with
an 8Mb chip. ART partition is moved to the end (0x7f0000). Also,
the commit adds the 741-related code back to the generic board.d
files.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts b/target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts
new file mode 100644 (file)
index 0000000..46dbbee
--- /dev/null
@@ -0,0 +1,40 @@
+#include "ar7240_tplink_tl-wr.dtsi"
+
+/ {
+       model = "TP-Link TL-WR741N/ND v1/v2 8Mb custom board";
+       compatible = "tplink,tl-wr741-v1-8m", "qca,ar7240";
+};
+
+/delete-node/ &art;
+
+&spi {
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               reg = <0x0 0x20000>;
+                               label = "u-boot";
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               reg = <0x20000 0x7d0000>;
+                               label = "firmware";
+                               compatible = "tplink,firmware";
+                       };
+
+                       art: partition@7f0000 {
+                               reg = <0x7f0000 0x10000>;
+                               label = "art";
+                               read-only;
+                       };
+               };
+       };
+};
index 57af593482b53d55aa05d318e1158b04746a0bdb..ae5d9fd2b2965cb2524998e586ee7dccafa4df64 100644 (file)
@@ -470,6 +470,13 @@ tplink,tl-mr6400-v1)
 tplink,tl-wpa8630-v1)
        ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x3c"
        ;;
+tplink,tl-wr741-v1-8m)
+       ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth0"
+       ucidef_set_led_switch "lan1" "LAN1" "green:lan1" "switch0" "0x02"
+       ucidef_set_led_switch "lan2" "LAN2" "green:lan2" "switch0" "0x04"
+       ucidef_set_led_switch "lan3" "LAN3" "green:lan3" "switch0" "0x08"
+       ucidef_set_led_switch "lan4" "LAN4" "green:lan4" "switch0" "0x10"
+       ;;
 tplink,tl-wr841hp-v2|\
 tplink,tl-wr842n-v2)
        ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
index 09d11cffe3203546d4a8a733b5944c08d73230ca..cdb9ada3e0db50306c70a740a04b04cc580679a7 100644 (file)
@@ -508,6 +508,11 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:3" "3:lan:2" "4:lan:1" "5:lan:4"
                ;;
+       tplink,tl-wr741-v1-8m)
+               ucidef_set_interface_wan "eth0"
+               ucidef_add_switch "switch0" \
+                       "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
+               ;;
        tplink,tl-wr841hp-v2|\
        tplink,tl-wr842n-v2|\
        tplink,tl-wr941hp-v1)
index e5f4870e6fdab6468c8196998830a77a6f708bc7..4a1096dfce3303ae81447410dea0973da953a12c 100644 (file)
@@ -110,6 +110,7 @@ case "$FIRMWARE" in
                ;;
        netgear,wnr2200-8m|\
        netgear,wnr2200-16m|\
+       tplink,tl-wr741-v1-8m|\
        tplink,tl-wr842n-v1)
                caldata_extract "art" 0x1000 0x3e0
                ;;
index 460297e7e997329043e5fe9a5af3250a13abfe21..5b34fcc944e00976ef0db447c84ec4849d3e313d 100644 (file)
@@ -823,6 +823,17 @@ define Device/tplink_tl-wr710n-v2.1
 endef
 TARGET_DEVICES += tplink_tl-wr710n-v2.1
 
+define Device/tplink_tl-wr741-v1-8m
+  $(Device/tplink-8m)
+  SOC := ar7240
+  DEVICE_MODEL := TL-WR741N/ND
+  DEVICE_VARIANT := v1/v2 8M
+  TPLINK_HWID := 0x07410001
+  DEVICE_PACKAGES := kmod-owl-loader
+  SUPPORTED_DEVICES += tl-wr741nd
+endef
+TARGET_DEVICES += tplink_tl-wr741-v1-8m
+
 define Device/tplink_tl-wr810n-v1
   $(Device/tplink-8mlzma)
   SOC := qca9531