ipq40xx: disable devices with 3MiB kernel size
authorSungbo Eo <mans0n@gorani.run>
Sun, 18 Sep 2022 01:13:56 +0000 (10:13 +0900)
committerSungbo Eo <mans0n@gorani.run>
Sun, 18 Sep 2022 12:33:50 +0000 (21:33 +0900)
The image builds for Linksys EA6350 v3, EA8300, and MR8300 currently
fail on buildbots due to the KERNEL_SIZE, as stated in commit
17b7756b5a20 ("ipq40xx: 5.15: add testing kernel version"). Disable
these boards for now.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ipq40xx/image/generic.mk

index 8e15f7ea20da0a56deb201d846ee84d25259c650..dfb235c8d542fd94ee6ef279ee577c365e4f5ce8 100644 (file)
@@ -640,6 +640,7 @@ define Device/linksys_ea6350v3
        UBINIZE_OPTS := -E 5
        IMAGES += factory.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
+       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_ea6350v3
 
@@ -656,6 +657,7 @@ define Device/linksys_ea8300
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
+       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_ea8300
 
@@ -672,6 +674,7 @@ define Device/linksys_mr8300
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
+       DEFAULT := n
 endef
 TARGET_DEVICES += linksys_mr8300