kernel: bump 4.14 to 4.14.97
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Jan 2019 15:38:20 +0000 (16:38 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 1 Feb 2019 10:41:39 +0000 (11:41 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/420-enable-CONFIG_MMC_SDHCI_IO_ACCESSORS.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/644-net-pppoe-support-hardware-flow-table-offload.patch
target/linux/generic/pending-4.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/mediatek/patches-4.14/0190-usb-xhci-mtk-supports-remote-wakeup-for-mt2712-with-.patch
target/linux/ramips/patches-4.14/0046-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch

index 20e0ca03fa71e5f4dcbb3901c801d7315118d188..1dde5962e57022350f6ab2c60ef3a9a4a610d082 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .154
-LINUX_VERSION-4.14 = .96
+LINUX_VERSION-4.14 = .97
 
 LINUX_KERNEL_HASH-4.9.154 = 5b314f1ac16f78e10acea0053f0c758e696b28f80272064e0a06bc69dc9d5696
-LINUX_KERNEL_HASH-4.14.96 = 110daeae1a416b7e0ec8dce5e86d67552deeb4567f696c3869389be239f0ecb5
+LINUX_KERNEL_HASH-4.14.97 = 8dd2c831ddabfc6241ddca946e600376785fd6f225a24655bc36a0c6b4e945f4
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 744cf4cff26bbaf77b427bf178c4de1a89dc63be..eabfc64378e4e7778a2ff4aa28f6d859346bfd31 100644 (file)
@@ -13,11 +13,11 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -429,6 +429,7 @@ config MMC_SDHCI_MSM
-       tristate "Qualcomm SDHCI Controller Support"
-       depends on ARCH_QCOM || (ARM && COMPILE_TEST)
+@@ -310,6 +310,7 @@ config MMC_SDHCI_BCM_KONA
+       tristate "SDHCI support on Broadcom KONA platform"
+       depends on ARCH_BCM_MOBILE
        depends on MMC_SDHCI_PLTFM
 +      select MMC_SDHCI_IO_ACCESSORS
        help
-         This selects the Secure Digital Host Controller Interface (SDHCI)
-         support present in Qualcomm SOCs. The controller supports
+         This selects the Broadcom Kona Secure Digital Host Controller
+         Interface(SDHCI) support.
index d7b681942ef83be46d763e804a080872ffba062a..6b46c054d3e68098970579724055e1454c69d699 100644 (file)
@@ -339,7 +339,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2731,10 +2731,12 @@ static const struct file_operations fib_
+@@ -2740,10 +2740,12 @@ static const struct file_operations fib_
  
  int __net_init fib_proc_init(struct net *net)
  {
@@ -354,7 +354,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2744,17 +2746,21 @@ int __net_init fib_proc_init(struct net
+@@ -2753,17 +2755,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index edba04ccf6f68e66ec0ad51bd90ff51f4e0e2a53..ae8c4ca92130b9a522ef3697e1204265c44f4b4e 100644 (file)
@@ -73,7 +73,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <linux/nsproxy.h>
  #include <net/net_namespace.h>
  #include <net/netns/generic.h>
-@@ -977,8 +982,36 @@ static int pppoe_xmit(struct ppp_channel
+@@ -978,8 +983,36 @@ static int pppoe_xmit(struct ppp_channel
        return __pppoe_xmit(sk, skb);
  }
  
index 36aaccbdb3e1dcb761eeb9ab82f7747cbc480f48..03bb755619087765bc50dddc3cc03b7b49298c85 100644 (file)
@@ -66,7 +66,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static void rt_fibinfo_free(struct rtable __rcu **rtp)
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2460,6 +2460,7 @@ static const char *const rtn_type_names[
+@@ -2469,6 +2469,7 @@ static const char *const rtn_type_names[
        [RTN_THROW] = "THROW",
        [RTN_NAT] = "NAT",
        [RTN_XRESOLVE] = "XRESOLVE",
index 2ae76eda17ddbf93c403fabca64ff0695d71cd36..c49efcbd382dbdd0a24d8753b728e8ad3b43e588 100644 (file)
@@ -229,7 +229,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
  
        mtk->num_phys = of_count_phandle_with_args(node,
                        "phys", "#phy-cells");
-@@ -780,7 +723,7 @@ static int __maybe_unused xhci_mtk_suspe
+@@ -782,7 +725,7 @@ static int __maybe_unused xhci_mtk_suspe
        xhci_mtk_host_disable(mtk);
        xhci_mtk_phy_power_off(mtk);
        xhci_mtk_clks_disable(mtk);
@@ -238,7 +238,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        return 0;
  }
  
-@@ -790,7 +733,7 @@ static int __maybe_unused xhci_mtk_resum
+@@ -792,7 +735,7 @@ static int __maybe_unused xhci_mtk_resum
        struct usb_hcd *hcd = mtk->hcd;
        struct xhci_hcd *xhci = hcd_to_xhci(hcd);
  
index 4c4147ef52fcbc8fc0194b11d9e85db16c16b002..0535811ea3127d10fc5f91507a4652b39509c45b 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -900,3 +900,5 @@ config MMC_SDHCI_XENON
+@@ -901,3 +901,5 @@ config MMC_SDHCI_XENON
          This selects Marvell Xenon eMMC/SD/SDIO SDHCI.
          If you have a controller with this interface, say Y or M here.
          If unsure, say N.