Use lzma kernel compression.
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 11 Apr 2010 22:12:10 +0000 (22:12 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 11 Apr 2010 22:12:10 +0000 (22:12 +0000)
SVN-Revision: 20815

target/linux/mx2/config-2.6.34
target/linux/mx2/patches-2.6.34/030-lzma.patch [new file with mode: 0644]

index 478e552058596e4a6dbda1450c7c572e6a0cab75..0ffddaee49eff725b8473b703b0655cba88ccab2 100644 (file)
@@ -48,7 +48,8 @@ CONFIG_DECOMPRESS_LZMA=y
 # CONFIG_DEFAULT_SECURITY_SELINUX is not set
 # CONFIG_DEFAULT_SECURITY_SMACK is not set
 # CONFIG_DEFAULT_SECURITY_TOMOYO is not set
-# CONFIG_DM9000 is not set
+CONFIG_DEVTMPFS=y
+CONFIG_DEVTMPFS_MOUNT=y
 # CONFIG_FPE_FASTFPE is not set
 # CONFIG_FPE_NWFPE is not set
 CONFIG_FRAME_POINTER=y
@@ -61,6 +62,7 @@ CONFIG_GENERIC_GPIO=y
 CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ=y
 CONFIG_GPIOLIB=y
 # CONFIG_GPIO_IT8761E is not set
+CONFIG_GPIO_SYSFS=y
 CONFIG_HARDIRQS_SW_RESEND=y
 CONFIG_HAS_DMA=y
 CONFIG_HAS_IOMEM=y
@@ -72,6 +74,7 @@ CONFIG_HAVE_FUNCTION_TRACER=y
 CONFIG_HAVE_GENERIC_DMA_COHERENT=y
 CONFIG_HAVE_IDE=y
 CONFIG_HAVE_KERNEL_GZIP=y
+CONFIG_HAVE_KERNEL_LZMA=y
 CONFIG_HAVE_KERNEL_LZO=y
 CONFIG_HAVE_KPROBES=y
 CONFIG_HAVE_KRETPROBES=y
@@ -115,8 +118,6 @@ CONFIG_INPUT_KEYBOARD=y
 # CONFIG_ISDN_CAPI is not set
 # CONFIG_ISDN_DRV_GIGASET is not set
 # CONFIG_ISDN_I4L is not set
-CONFIG_KERNEL_GZIP=y
-# CONFIG_KERNEL_LZMA is not set
 CONFIG_KEYBOARD_ATKBD=y
 # CONFIG_KEYBOARD_GPIO is not set
 # CONFIG_KEYBOARD_IMX is not set
@@ -142,6 +143,8 @@ CONFIG_MTD_PHYSMAP=y
 # CONFIG_MXC_IRQ_PRIOR is not set
 # CONFIG_MXC_PWM is not set
 CONFIG_NEED_DMA_MAP_STATE=y
+# CONFIG_NETDEV_1000 is not set
+# CONFIG_NET_ETHERNET is not set
 CONFIG_PAGEFLAGS_EXTENDED=y
 CONFIG_PAGE_OFFSET=0xC0000000
 # CONFIG_PCI_SYSCALL is not set
diff --git a/target/linux/mx2/patches-2.6.34/030-lzma.patch b/target/linux/mx2/patches-2.6.34/030-lzma.patch
new file mode 100644 (file)
index 0000000..9ccabf6
--- /dev/null
@@ -0,0 +1,73 @@
+This patch allows using a kernel image compressed with LZMA on ARM.
+Extracting the image is fairly slow, but it might be useful on machines
+with a very limited amount of storage, as the size benefit is quite
+significant:
+Gzip: Data Size:    1586352 Bytes = 1549.17 kB = 1.51 MB
+LZMA: Data Size:    2135916 Bytes = 2085.86 kB = 2.04 MB
+
+Signed-off-by: Albin Tonnerre <albin.tonnerre <at> free-electrons.com>
+Tested-by: Martin Michlmayr <tbm <at> cyrius.com>
+---
+v2: Updated to apply on top of 2.6.34-rc1
+
+ arch/arm/Kconfig                      |    1 +
+ arch/arm/boot/compressed/Makefile     |    1 +
+ arch/arm/boot/compressed/decompress.c |    4 ++++
+ arch/arm/boot/compressed/piggy.lzma.S |    6 ++++++
+ 4 files changed, 12 insertions(+), 0 deletions(-)
+ create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
+
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 3b18128..3ebc7c3 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -21,6 +21,7 @@ config ARM
+       select HAVE_GENERIC_DMA_COHERENT
+       select HAVE_KERNEL_GZIP
+       select HAVE_KERNEL_LZO
++      select HAVE_KERNEL_LZMA
+       select HAVE_PERF_EVENTS
+       select PERF_USE_VMALLOC
+       help
+diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
+index 97c89e7..53faa90 100644
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -65,6 +65,7 @@ SEDFLAGS     = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
+
+ suffix_$(CONFIG_KERNEL_GZIP) = gzip
+ suffix_$(CONFIG_KERNEL_LZO)  = lzo
++suffix_$(CONFIG_KERNEL_LZMA) = lzma
+
+ targets       := vmlinux vmlinux.lds \
+                piggy.$(suffix_y) piggy.$(suffix_y).o \
+diff --git a/arch/arm/boot/compressed/decompress.c b/arch/arm/boot/compressed/decompress.c
+index 0da382f..d554df6 100644
+--- a/arch/arm/boot/compressed/decompress.c
++++ b/arch/arm/boot/compressed/decompress.c
+@@ -39,6 +39,10 @@ extern void error(char *);
+ #include "../../../../lib/decompress_unlzo.c"
+ #endif
+
++#ifdef CONFIG_KERNEL_LZMA
++#include "../../../../lib/decompress_unlzma.c"
++#endif
++
+ void do_decompress(u8 *input, int len, u8 *output, void (*error)(char *x))
+ {
+       decompress(input, len, NULL, NULL, output, NULL, error);
+diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
+new file mode 100644
+index 0000000..d7e69cf
+--- /dev/null
++++ b/arch/arm/boot/compressed/piggy.lzma.S
+@@ -0,0 +1,6 @@
++      .section .piggydata,#alloc
++      .globl  input_data
++input_data:
++      .incbin "arch/arm/boot/compressed/piggy.lzma"
++      .globl  input_data_end
++input_data_end:
+-- 
+1.7.0
+