merge r14442 to 8.09 (closes: #4554)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Apr 2009 13:42:07 +0000 (13:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Apr 2009 13:42:07 +0000 (13:42 +0000)
SVN-Revision: 15169

multimedia/qc-usb/Makefile
multimedia/qc-usb/patches/002-qc_set_cross_compile.patch [new file with mode: 0644]

index 9f6a82e958b59618522005dd2da59147cfe00ce6..4b967d06f41afc3f6afd0d4cc97e7dc926c4887c 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=qc-usb
 PKG_VERSION:=0.6.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/qce-ga
@@ -73,6 +73,7 @@ endif
 
 define Build/Compile/user
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                qcset
 endef
diff --git a/multimedia/qc-usb/patches/002-qc_set_cross_compile.patch b/multimedia/qc-usb/patches/002-qc_set_cross_compile.patch
new file mode 100644 (file)
index 0000000..e3d8c2d
--- /dev/null
@@ -0,0 +1,12 @@
+diff -rupN original/Makefile new/Makefile
+--- original/Makefile  2006-10-23 21:06:19.000000000 -0500
++++ new/Makefile       2009-02-03 08:57:20.000000000 -0600
+@@ -183,7 +183,7 @@ install: $(MODULE_NAME)
+       -$(DEPMOD) -a
+ qcset: qcset.c quickcam.h
+-      gcc -Wall -O2 -s qcset.c -o qcset -lm
++      $(CC) -Wall -O2 -s qcset.c -o qcset -lm
+ .PHONY: patch
+ patch: kernel-patch kernel-files