uboot-zynq: automatically select the appropriate variant
authorLuis Araneda <luaraneda@gmail.com>
Tue, 4 Sep 2018 01:39:57 +0000 (22:39 -0300)
committerJohn Crispin <john@phrozen.org>
Mon, 10 Sep 2018 06:54:00 +0000 (08:54 +0200)
Select the U-Boot variant automatically based on the
current selected device, and hide the package from
menuconfig

Signed-off-by: Luis Araneda <luaraneda@gmail.com>
package/boot/uboot-zynq/Makefile

index 65ac93bfbd3db454885fc434dd1f3ab52053c81b..c4779249c4a1b4470f8b7425c087615ea230bd0d 100644 (file)
@@ -20,22 +20,27 @@ define U-Boot/Default
   BUILD_TARGET:=zynq
   UBOOT_IMAGE:=spl/boot.bin u-boot.img
   UBOOT_CONFIG:=zynq_$(1)
+  HIDDEN:=1
 endef
 
 define U-Boot/zc702
   NAME:=Xilinx ZC702 Dev Board
+  BUILD_DEVICES:=xlnx_zynq-zc702
 endef
 
 define U-Boot/zed
   NAME:=Avnet Digilent ZedBoard Dev Board
+  BUILD_DEVICES:=avnet_zynq-zed
 endef
 
 define U-Boot/zybo
   NAME:=Digilent Zybo Dev Board
+  BUILD_DEVICES:=digilent_zynq-zybo
 endef
 
 define U-Boot/zybo_z7
   NAME:=Digilent Zybo Z7 board
+  BUILD_DEVICES:=digilent_zynq-zybo-z7
 endef
 
 UBOOT_TARGETS := \