prereq-build: add python 3.9 support
authorRosen Penev <rosenp@gmail.com>
Thu, 29 Oct 2020 07:12:16 +0000 (00:12 -0700)
committerPaul Spooren <mail@aparcar.org>
Wed, 25 Nov 2020 09:40:39 +0000 (23:40 -1000)
Fixes unmet dependency issue.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index 8181812599f2346cde6e4d720daef4b8d23ede88..e7314b253b58610c5c0b8264f251e1345eacde7c 100644 (file)
@@ -149,6 +149,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
@@ -156,6 +157,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \