kernel: bump 4.14 to 4.14.67
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Aug 2018 16:00:10 +0000 (18:00 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 28 Aug 2018 21:06:48 +0000 (23:06 +0200)
Refreshed all patches.

Removed upstreamed patches:
- 037-v4.18-0008-ARM-dts-BCM5301x-Fix-i2c-controller-interrupt-type.patch

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/bcm53xx/patches-4.14/037-v4.18-0008-ARM-dts-BCM5301x-Fix-i2c-controller-interrupt-type.patch [deleted file]
target/linux/cns3xxx/patches-4.14/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
target/linux/generic/backport-4.14/324-v4.16-netfilter-flow-table-support-for-IPv6.patch
target/linux/generic/backport-4.14/335-v4.16-netfilter-nf_tables-add-single-table-list-for-all-fa.patch
target/linux/generic/backport-4.14/350-v4.18-ipv6-make-ip6_dst_mtu_forward-inline.patch
target/linux/generic/pending-4.14/630-packet_socket_type.patch
target/linux/ipq40xx/patches-4.14/830-usb-dwc3-register-qca-ipq4019-dwc3-in-dwc3-of-simple.patch
target/linux/ipq806x/patches-4.14/0074-ipq806x-usb-Control-USB-master-reset.patch
target/linux/lantiq/patches-4.14/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/ramips/patches-4.14/0032-USB-dwc2-add-device_reset.patch

index 9c9490fef64273fc7621fd50e5b5121d13ed0185..425c7ab594e005246c1af2488a2f0310fb274b27 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.14 = .66
 LINUX_VERSION-4.9 = .124
+LINUX_VERSION-4.14 = .67
 
-LINUX_KERNEL_HASH-4.14.66 = a38061ca4c864d11a72beb3dc5918a99f13372fe9ee35508d004fdfabd460413
 LINUX_KERNEL_HASH-4.9.124 = 5ca6b0d48c8dd1265005169f1b97149a4e893668c0d8aa566a73c7663c8e4311
+LINUX_KERNEL_HASH-4.14.67 = 3f4b056dc27233a78f7a4a35ed6fdcfd0a9680ec40b611a898bb6c8b905070ba
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/bcm53xx/patches-4.14/037-v4.18-0008-ARM-dts-BCM5301x-Fix-i2c-controller-interrupt-type.patch b/target/linux/bcm53xx/patches-4.14/037-v4.18-0008-ARM-dts-BCM5301x-Fix-i2c-controller-interrupt-type.patch
deleted file mode 100644 (file)
index 6f06286..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From a0a8338e905734518ab9b10b06e7fd0201228f8b Mon Sep 17 00:00:00 2001
-From: Florian Fainelli <f.fainelli@gmail.com>
-Date: Mon, 11 Jun 2018 15:53:40 -0700
-Subject: [PATCH] ARM: dts: BCM5301x: Fix i2c controller interrupt type
-
-The i2c controller should be using IRQ_TYPE_LEVEL_HIGH, fix that.
-
-Fixes: bb097e3e0045 ("ARM: dts: BCM5301X: Add I2C support to the DT")
-Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
----
- arch/arm/boot/dts/bcm5301x.dtsi | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/boot/dts/bcm5301x.dtsi
-+++ b/arch/arm/boot/dts/bcm5301x.dtsi
-@@ -365,7 +365,7 @@
-       i2c0: i2c@18009000 {
-               compatible = "brcm,iproc-i2c";
-               reg = <0x18009000 0x50>;
--              interrupts = <GIC_SPI 121 IRQ_TYPE_NONE>;
-+              interrupts = <GIC_SPI 121 IRQ_TYPE_LEVEL_HIGH>;
-               #address-cells = <1>;
-               #size-cells = <0>;
-               clock-frequency = <100000>;
index 45946e3d6730e90074d1df13834fd5ffa311a8ae..c0161e7a30a011deb9c5e587821ccac37535ec3b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/probe.c
 +++ b/drivers/pci/probe.c
-@@ -2305,7 +2305,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -2309,7 +2309,8 @@ static void pcie_write_mrrs(struct pci_d
        /* In the "safe" case, do not configure the MRRS.  There appear to be
         * issues with setting MRRS to 0 on a number of devices.
         */
index 874195558c4e0e6607532c853763881705dd88cd..2e8cb2016377d2ade36f78bc07d24a33d4da41e0 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 
 --- a/include/net/ipv6.h
 +++ b/include/net/ipv6.h
-@@ -918,6 +918,8 @@ static inline struct sk_buff *ip6_finish
+@@ -911,6 +911,8 @@ static inline struct sk_buff *ip6_finish
                              &inet6_sk(sk)->cork);
  }
  
index 320a90c11cc06ec2f43d07ab180d3024fde85707..47ba98c1910ad2a69f7c9483ab821e9d489c6901 100644 (file)
@@ -1280,8 +1280,8 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 -      family = ctx->afi->family;
 +      family = ctx->family;
  
-       /* Re-use the existing target if it's already loaded. */
-       list_for_each_entry(nft_target, &nft_target_list, head) {
+       if (strcmp(tg_name, XT_ERROR_TARGET) == 0 ||
+           strcmp(tg_name, XT_STANDARD_TARGET) == 0 ||
 --- a/net/netfilter/nft_ct.c
 +++ b/net/netfilter/nft_ct.c
 @@ -405,7 +405,7 @@ static int nft_ct_get_init(const struct
index 9ed9ca558dca8ad0adef7a349aab80de2c980ff6..f90f4152399fc6caccac984e0004c4811c8d70d9 100644 (file)
@@ -38,7 +38,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif
 --- a/include/net/ipv6.h
 +++ b/include/net/ipv6.h
-@@ -918,8 +918,6 @@ static inline struct sk_buff *ip6_finish
+@@ -911,8 +911,6 @@ static inline struct sk_buff *ip6_finish
                              &inet6_sk(sk)->cork);
  }
  
index 82e2c51afddcd82b9b47b79d6a6a00a5af4642e6..e1736214f5e63a6afaed64c6e85ae9752f5b5c81 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3260,6 +3262,7 @@ static int packet_create(struct net *net
+@@ -3262,6 +3264,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3873,6 +3876,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3875,6 +3878,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3925,6 +3938,13 @@ static int packet_getsockopt(struct sock
+@@ -3927,6 +3940,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index e9b33446d97d1c3d5f2bf8e923c6805cda171a4b..a3bd35d9c6d667910d4dca4223a8f9cf92ec1f3a 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
 
 --- a/drivers/usb/dwc3/dwc3-of-simple.c
 +++ b/drivers/usb/dwc3/dwc3-of-simple.c
-@@ -176,6 +176,7 @@ static const struct dev_pm_ops dwc3_of_s
+@@ -177,6 +177,7 @@ static const struct dev_pm_ops dwc3_of_s
  
  static const struct of_device_id of_dwc3_simple_match[] = {
        { .compatible = "qcom,dwc3" },
index 24cfd1802044e1e2ceb84f0de2f89947d4e13b07..ee410ca6fae2eb4da4339813b1bdf93bce502621 100644 (file)
@@ -68,4 +68,4 @@ Signed-off-by: Vasudevan Murugesan <vmuruges@codeaurora.org>
 +
        of_platform_depopulate(dev);
  
-       pm_runtime_put_sync(dev);
+       pm_runtime_disable(dev);
index 77351e1791434df77a592f319aaf5d576a96cf2b..f72f39448b0d20e304bdd744b62743d647e33b47 100644 (file)
@@ -5494,7 +5494,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1300,6 +1300,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1302,6 +1302,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
index 7e120c531125d568fceefa24a9e64c63e5ba41ca..d9449eb39f8c2b317f4642e5f207af3c76970750 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <linux/usb/hcd.h>
  #include <linux/usb/ch11.h>
-@@ -5107,6 +5108,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
+@@ -5171,6 +5172,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
  
        retval = -ENOMEM;