brcm63xx: allow lzma to use 32MB RAM
authorJonas Gorski <jogo@openwrt.org>
Fri, 27 Feb 2015 17:38:28 +0000 (17:38 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 27 Feb 2015 17:38:28 +0000 (17:38 +0000)
Most 16 MiB RAM devices don't even load elf kernels, so it's safe to
assume we have at least 32 MB RAM. This fixes tftp booting with the
default package set as this already produces an uncompressed
kernel > 8 MiB.

New limit is 8 MiB compressed / 24 MiB compressed.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44558

target/linux/brcm63xx/image/Makefile

index d771c0937010284de10c6e9c356f0829b0badd76..a7d856a9e2ec2c5e73a2dc9308eec1b66598ace3 100755 (executable)
@@ -7,15 +7,17 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-LOADADDR = 0x80010000          # RAM start + 16M 
+LOADADDR = 0x80010000          # RAM start + 64K
 KERNEL_ENTRY = $(LOADADDR)     # Newer kernels add a jmp to the kernel_entry at the start of the binary
-RAMSIZE = 0x01000000           # 64MB
+RAMSIZE = 0x02000000           # 32MB
+LZMA_TEXT_START = 0x81800000   # 32MB - 8MB
 
 LOADER_MAKEOPTS= \
                KDIR=$(KDIR) \
                LOADADDR=$(LOADADDR) \
                KERNEL_ENTRY=$(KERNEL_ENTRY) \
-               RAMSIZE=$(RAMSIZE)
+               RAMSIZE=$(RAMSIZE) \
+               LZMA_TEXT_START=$(LZMA_TEXT_START) \
 
 define rootfspad/jffs2-128k
 --align-rootfs
@@ -124,7 +126,6 @@ define Image/PrepareLoader
                TARGET_DIR="$(BIN_DIR)" \
                LOADER_DATA="$(KDIR)/vmlinux$(1).lzma" \
                LOADER=$(IMG_PREFIX)-loader$(1).elf \
-               LZMA_TEXT_START=0x80a00000 \
                compile loader.elf
 
        rm -f $(KDIR)/vmlinux$(1).lzma