target: include selinux-variants if CONFIG_SELINUX is set
authorDaniel Golle <daniel@makrotopia.org>
Mon, 19 Oct 2020 15:55:39 +0000 (16:55 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 21 Oct 2020 10:56:26 +0000 (11:56 +0100)
Rather than unconditionally adding busybox and procd to the set of
default packages, add busybox-selinux and procd-selinux in case
CONFIG_SELINUX is set.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/target.mk
package/base-files/Makefile

index 31ce592c8bb777848c49241114589390bc78ce56..a2e76f8149b739ddd3880faf7bb7103410f7a3ec 100644 (file)
@@ -15,7 +15,6 @@ DEVICE_TYPE?=router
 # Default packages - the really basic set
 DEFAULT_PACKAGES:=\
        base-files \
-       busybox \
        ca-bundle \
        dropbear \
        fstools \
@@ -30,6 +29,13 @@ DEFAULT_PACKAGES:=\
        uclient-fetch \
        urandom-seed \
        urngd
+
+ifneq ($(CONFIG_SELINUX),)
+DEFAULT_PACKAGES+=busybox-selinux procd-selinux
+else
+DEFAULT_PACKAGES+=busybox procd
+endif
+
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets
index bf6b5c3c9a27be53cef245b38ebd63fbf89c0aaa..27bf7ae3f96d2858f34be36a4555fe99cdce558c 100644 (file)
@@ -37,7 +37,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)