linux-firmware: move firmware file for mt7601u
authorDaniel Golle <daniel@makrotopia.org>
Mon, 15 May 2023 19:56:27 +0000 (21:56 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 15 May 2023 20:03:46 +0000 (22:03 +0200)
The firmware file for mt7601u (MediaTek MT7601U Wireless MACs) has
been moved to the mediatek/ folder by commit
 8451c2b1 mt76xx: Move the old Mediatek WiFi firmware to mediatek

Address this by updating the location of the firmware file in our
linux-firmware Makefile generating the mt7601u-firmware package.

All other MediaTek Wi-Fi firmware files are supplied by OpenWrt's
own repository rather than being taken from linux-firmware.

Fixes: d53fe5d9ce ("linux-firmware: update to 20230515")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/firmware/linux-firmware/mediatek.mk

index 77167aa8fe5fe4c27d1c925050b5d4a44d171d04..a0eccb8f4d5811744842d7e8d75dc9834e914e5e 100644 (file)
@@ -1,9 +1,9 @@
 Package/mt7601u-firmware = $(call Package/firmware-default,MediaTek MT7601U firmware)
 define Package/mt7601u-firmware/install
-       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
        $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/mt7601u.bin \
-               $(1)/lib/firmware
+               $(PKG_BUILD_DIR)/mediatek/mt7601u.bin \
+               $(1)/lib/firmware/mediatek
 endef
 $(eval $(call BuildPackage,mt7601u-firmware))