modules: block: add libraid module
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 24 Oct 2023 16:40:24 +0000 (18:40 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 24 Oct 2023 21:23:22 +0000 (23:23 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/block.mk

index 4ee3f78f3809a25d0442b7c0e3512ed6c284f072..ac5510e2a1c4d48332d276044ff0967a7faeda6e 100644 (file)
@@ -443,6 +443,23 @@ endef
 $(eval $(call KernelPackage,libsas,1))
 
 
+define KernelPackage/libraid
+  SUBMENU:=$(BLOCK_MENU)
+  DEPENDS:=@TARGET_x86
+  TITLE:=RAID Transport class
+  KCONFIG:=CONFIG_RAID_ATTRS
+  FILES:= \
+       $(LINUX_DIR)/drivers/scsi/raid_class.ko
+  AUTOLOAD:=$(call AutoLoad,29,raid_class,1)
+endef
+
+define KernelPackage/libraid/description
+ RAID Transport Attributes support
+endef
+
+$(eval $(call KernelPackage,libraid,1))
+
+
 define KernelPackage/loop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Loopback device support