toolchaini/gcc: fix libstdc++ dual abi model
authorIvan Maslov <avenger_msoft@mail.ru>
Sat, 29 Jan 2022 20:11:30 +0000 (23:11 +0300)
committerPetr Štetiar <ynezz@true.cz>
Mon, 16 Jan 2023 07:45:38 +0000 (08:45 +0100)
libstdcxx-dual-abi needs to be enabled to actually support C++11 ABI.
Enable the config flag to also permit support of .NET 6 development on
OpenWrt.

Signed-off-by: Ivan Maslov <avenger_msoft@mail.ru>
[ reword commit description and title ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit 3c06a344e9c7c03c49c9153342e68a5390651323)

toolchain/gcc/common.mk

index bef4fa37f8f90466c304c4a3c836d4912ea5025f..fb280e942f32e4ed341bac76313442676dbcdcf2 100644 (file)
@@ -115,7 +115,7 @@ GCC_CONFIGURE:= \
                --disable-decimal-float \
                --with-diagnostics-color=auto-if-env \
                --enable-__cxa_atexit \
-               --disable-libstdcxx-dual-abi \
+               --enable-libstdcxx-dual-abi \
                --with-default-libstdcxx-abi=new
 ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt