hostapd: remove erroneous $(space) redefinition
authorJo-Philipp Wich <jo@mein.io>
Sat, 8 Feb 2020 10:34:41 +0000 (11:34 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sat, 8 Feb 2020 10:46:27 +0000 (11:46 +0100)
The $(space) definition in the hostapd Makefile ceased to work with
GNU Make 4.3 and later, leading to syntax errors in the generated
Kconfig files.

Drop the superfluous redefinition and reuse the working $(space)
declaration from rules.mk to fix this issue.

Fixes: GH#2713
Ref: https://github.com/openwrt/openwrt/pull/2713#issuecomment-583722469
Reported-by: Karel Kočí <cynerd@email.cz>
Suggested-by: Jonas Gorski <jonas.gorski@gmail.com>
Tested-by: Shaleen Jain <shaleen@jain.sh>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 766e778226f5d4c6ec49ce22b101a5dbd4306644)

package/network/services/hostapd/Makefile

index 86534054b850855db5f66407b6f6d48f6153934b..48dff3494212963579e528c30dbbf8b30d670d42 100644 (file)
@@ -86,9 +86,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
-space :=
-space +=
-
 ifneq ($(LOCAL_VARIANT),mini)
   DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
 endif