mt7621: hiwifi_hc5962: fix reboot loop by using LZMA loader
authorPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 06:55:46 +0000 (08:55 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 17:05:06 +0000 (19:05 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

References: https://github.com/openwrt/openwrt/issues/10645#issuecomment-1282607274
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/image/mt7621.mk

index f7bb0590d75f14aed891face2f43a5f6ec6abe33..c1a9ecfaeb5242576e9200e9a5d1b97861fbe414 100644 (file)
@@ -880,6 +880,7 @@ TARGET_DEVICES += hilink_hlk-7621a-evb
 
 define Device/hiwifi_hc5962
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL_SIZE := 4096k