OpenWrt v19.07: set branch defaults
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 10 Jun 2019 20:16:09 +0000 (22:16 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 10 Jun 2019 23:53:08 +0000 (01:53 +0200)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
feeds.conf.default
include/version.mk
package/base-files/image-config.in

index da6c6656244f4ae41a05ad91d7031e1fe78cc711..42c2b0ba3b935b23290efadafe93e1c674a6769a 100644 (file)
@@ -1,9 +1,4 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git management https://github.com/openwrt-management/packages.git
-#src-git oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-19.07
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-19.07
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-19.07
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-19.07
index 7d3c1ad6400f24be25e58b50a5f8549a761bc156..db0167d811627d9917b683f4453fabbe42619816 100644 (file)
@@ -26,13 +26,13 @@ PKG_CONFIG_DEPENDS += \
 sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
 
 VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),19.07-SNAPSHOT)
 
 VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/releases/19.07-SNAPSHOT)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index 3432db525a14c46eafa3325401a536017f3d2cbf..560b66dfc91b81f8a9d553c8b07eeb599fb9b6b2 100644 (file)
@@ -183,7 +183,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots"
+               default "http://downloads.openwrt.org/releases/19.07-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: