ipq40xx: add Aruba AP-365 specific BDF
authorDavid Bauer <mail@david-bauer.net>
Wed, 25 May 2022 20:07:10 +0000 (22:07 +0200)
committerDavid Bauer <mail@david-bauer.net>
Thu, 2 Jun 2022 14:50:12 +0000 (16:50 +0200)
Aruba deploys a BDF in the root filesystem, however this matches the one
used for the DK04 reference board.

The board-specific BDFs are built into the kernel. The AP-365 shows
sinificant degraded performance with increased range when used with the
reference BDF.

Replace the BDF with the one extracted from Arubas kernel.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
target/linux/ipq40xx/image/generic.mk

index cd155473bbdec47b0dcf976a7081f0b26c3b3bc0..f8445f0e3383be78b1c84b1001c5a6654a0404b2 100644 (file)
@@ -25,6 +25,7 @@ endef
 # <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
 
 ALLWIFIBOARDS:= \
+       aruba_ap-365 \
        devolo_magic-2-wifi-next \
        edgecore_ecw5410 \
        edgecore_oap100 \
@@ -96,6 +97,7 @@ endef
 # Place files in this directory as board-<devicename>.<qca4019|qca9888|qca9984>
 # Add $(eval $(call generate-ipq-wifi-package,<devicename>,<display name>))
 
+$(eval $(call generate-ipq-wifi-package,aruba_ap-365,Aruba AP-365))
 $(eval $(call generate-ipq-wifi-package,devolo_magic-2-wifi-next,devolo Magic 2 WiFi next))
 $(eval $(call generate-ipq-wifi-package,edgecore_ecw5410,Edgecore ECW5410))
 $(eval $(call generate-ipq-wifi-package,edgecore_oap100,Edgecore OAP100))
diff --git a/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 b/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019
new file mode 100644 (file)
index 0000000..7fc44a6
Binary files /dev/null and b/package/firmware/ipq-wifi/board-aruba_ap-365.qca4019 differ
index d3cc73f388e380ebd5b0704c5c98d1eb6ccab918..1f7b37d56d6dc4eb21c2650a1da632232a5778f5 100644 (file)
                };
        };
 };
+
+&wifi0 {
+       qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
+&wifi1 {
+       qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
index b730a0e1840ab6eca7dfe7d6055fb40c9ea617b5..44880d157c59b471c564bb1b57bf0af44cf3d2e8 100644 (file)
@@ -185,7 +185,7 @@ TARGET_DEVICES += aruba_ap-303h
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
-       DEVICE_PACKAGES += kmod-hwmon-ad7418
+       DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
 endef
 TARGET_DEVICES += aruba_ap-365