prereq-build: add missing check for Perl IPC::Cmd
authorPetr Štetiar <ynezz@true.cz>
Fri, 26 May 2023 10:37:15 +0000 (12:37 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 28 May 2023 06:58:06 +0000 (08:58 +0200)
OpenSSL fails to compile in Fedora 38 container due to the following:

 Can't locate IPC/Cmd.pm in @INC (you may need to install the IPC::Cmd module) (@INC contains: /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl /usr/local/lib64/perl5/5.36 /usr/local/share/perl5/5.36 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/external/perl/Text-Template-1.56/lib) at /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl/OpenSSL/config.pm line 19.
 BEGIN failed--compilation aborted at /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl/OpenSSL/config.pm line 19.
 Compilation failed in require at ./Configure line 23.
 BEGIN failed--compilation aborted at ./Configure line 23.

Seems like `dnf install -y perl-IPC-Cmd` fixes the issue.

So lets fix it by checking for Perl IPC::Cmd host module availability.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/prereq-build.mk

index 9096e379bb0f7aa76e7fb5783e39015af40387f5..5b63490ca3c6754a4c2ac276310ec45331fff511 100644 (file)
@@ -94,6 +94,10 @@ $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))
 
+$(eval $(call TestHostCommand,perl-ipc-cmd, \
+       Please install the Perl IPC:Cmd module, \
+       perl -MIPC::Cmd -e 1))
+
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \
        gnutar --version 2>&1 | grep GNU, \