ipq807x: prpl-haze: fix sysupgrade flashing from bootloader
authorPetr Štetiar <ynezz@true.cz>
Thu, 29 Jun 2023 12:29:02 +0000 (14:29 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 29 Jan 2024 09:38:17 +0000 (09:38 +0000)
While flashing sysupgrade image from U-Boot, then the rootfs_data
overlay filesystem formatting is left for the fstools during firstboot,
but that wont work as mkfs.f2fs is missing in the sysupgrade image:

 mount_root: overlay filesystem in /dev/loop0 has not been formatted yet
 mount_root: no usable overlay filesystem found, using tmpfs overlay
 sh: mkfs.f2fs: not found

 Filesystem                Size      Used Available Use% Mounted on
 /dev/loop0              139.6M     46.9M     92.6M  34% /overlay

 Number  Start (sector)    End (sector)  Size       Code  Name
  20           98850          406349   150.1 MiB   FFFF  rootfs

So lets fix it by adding f2fs support to the sysupgrade image.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit ba415af5706f0369e4d299e4dfe50541a4a8056b)

target/linux/ipq807x/image/generic.mk

index fb991156d5de4b740dacdae0d4ea612d3b7ec1cc..104a6678945f6adde6f6ed3b7c263eee088bb99f 100644 (file)
@@ -103,7 +103,8 @@ define Device/prpl_haze
        DEVICE_MODEL := Haze
        DEVICE_DTS_CONFIG := config@hk09
        SOC := ipq8072
-       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
+       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci \
+               mkf2fs f2fsck kmod-fs-f2fs
 endef
 TARGET_DEVICES += prpl_haze