i2c-gpio-mux: fix build for 3.6+ kernels
authorFlorian Fainelli <florian@openwrt.org>
Sun, 11 Nov 2012 18:40:43 +0000 (18:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 11 Nov 2012 18:40:43 +0000 (18:40 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34152

package/kernel/modules/i2c.mk

index 6c65989683362a1cd5528ee063eed9f5d999e430..49d8250777e9bd39c4515841de7e0db730993deb 100644 (file)
@@ -197,8 +197,13 @@ endef
 
 $(eval $(call KernelPackage,i2c-mux))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+I2C_MUX_GPIO_MODULES:= \
+  CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/i2c-mux-gpio
+else
 I2C_MUX_GPIO_MODULES:= \
   CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
+endif
 
 define KernelPackage/i2c-mux-gpio
   $(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)