realtek: fix default image generation
authorSander Vanheule <sander@svanheule.net>
Wed, 28 Dec 2022 20:46:48 +0000 (21:46 +0100)
committerSander Vanheule <sander@svanheule.net>
Wed, 28 Dec 2022 21:44:10 +0000 (22:44 +0100)
While cleaning up the makefiles for the realtek target, the order of the
default image generating commands was accidentally changed. This caused
the image signature to end up somewhere in the middle, misaligning the
rootfs. As a result, sysupgrade couldn't verify upgrade images anymore,
and devices end up in a boot loop due to the unaligned (and not found)
rootfs.

Fixes: 94d8b4852b9f ("realtek: Cleanup Makefiles")
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/image/Makefile

index e4a3904aa83619cd39d000e7cd7bf25dedea2628..66d7ee489548758f91ebe2aea4b881d5b45a3651 100644 (file)
@@ -102,11 +102,11 @@ define Device/Default
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := \
        append-kernel | \
-       append-metadata | \
+       pad-to 64k | \
        append-rootfs | \
-       check-size | \
        pad-rootfs | \
-       pad-to 64k
+       check-size | \
+       append-metadata
 endef
 
 include $(SUBTARGET).mk