build: add support for python3.11 and higher
authorOscar Molnar <oscar@tymscar.com>
Sat, 6 Aug 2022 15:13:41 +0000 (16:13 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 13 Aug 2022 19:13:08 +0000 (21:13 +0200)
python3.11 beta is out but fails to run the makefile currently
this supports python versions from 3.6 to 3.99 with the python3 binary
it also checks specifically for 3.11 as it is the latest version out

Signed-off-by: Oscar Molnar <oscar@tymscar.com>
include/prereq-build.mk

index 7428c21e16237e4ccc9f0b52d7c0fbf713a6eb38..6c45327f013b7af0d8de28aa7aa493f71731d936 100644 (file)
@@ -169,20 +169,22 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+       python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+       python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
        python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|10)\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
 
 $(eval $(call TestHostCommand,python3-distutils, \
        Please install the Python3 distutils module, \