ipq40xx: fix image building for ZTE MF287 series
authorAndreas Böhler <dev@aboehler.at>
Tue, 12 Sep 2023 17:57:55 +0000 (19:57 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 18 Sep 2023 09:49:37 +0000 (11:49 +0200)
For the ZTE MF287 series, a special recovery image is built. The Makefile
worked fine on snapshot, but created corrupt images on the 23.05 images.
By using the appropriate variable, this should be fixed.

Signed-off-by: Andreas Böhler <dev@aboehler.at>
target/linux/ipq40xx/image/generic.mk

index 29778156df03565a5a77753f62e10b991c26614f..8fd7ab291531a16dc2dd8fe252f8bea6e98754fe 100644 (file)
@@ -1162,7 +1162,7 @@ define Device/zte_mf287_common
 #      exploit for the web interface
        IMAGES += factory.bin recovery.bin
        IMAGE/factory.bin  := append-ubi
-       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
 endef
 
 define Device/zte_mf287plus