image: always rebuild kernel loaders
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sun, 27 Mar 2022 21:15:48 +0000 (23:15 +0200)
committerDavid Bauer <mail@david-bauer.net>
Fri, 14 Oct 2022 21:13:02 +0000 (23:13 +0200)
Kernel loaders like the lzma-loader currently don't track changes to
their sources. This can lead to an old version of a loader to be used
when a build tree is not clean between builds.

As the loaders are tiny and the build times are insignificant, simply
force rebuilding them on every build to avoid this problem.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/image.mk

index 9e4e99958168579fad5cf0711a75fa773b2717ce..b3dfc9019aedbe4acebcbdff21f0ff237223f824 100644 (file)
@@ -517,7 +517,7 @@ endif
 define Device/Build/compile
   $$(_COMPILE_TARGET): $(KDIR)/$(1)
   $(eval $(call Device/Export,$(KDIR)/$(1)))
-  $(KDIR)/$(1):
+  $(KDIR)/$(1): FORCE
        $$(call concat_cmd,$(COMPILE/$(1)))
 
 endef