firewall3: update to git head
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Mar 2013 15:46:30 +0000 (15:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Mar 2013 15:46:30 +0000 (15:46 +0000)
 * Adds support for emitting hotplug events when creating and clearing zones (fixes miniupnpd)
 * Make NAT reflection direction configurable
 * Map init script stop action to flush
 * Map init script reload action to reload
 * Respect init script disabled state in hotplug handler

SVN-Revision: 35998

package/network/config/firewall3/Makefile
package/network/config/firewall3/files/firewall.hotplug
package/network/config/firewall3/files/firewall.init

index 5b20dadefed96d4dc0b136ad0f7a912e4473178a..342f4ad58d2871883c6e47dc34ca1002d6c60180 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-03-11
+PKG_VERSION:=2013-03-13
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=87c4f12e16ae726e20774ee58468fa751a79a2c1
+PKG_SOURCE_VERSION:=ff9d5e13c9150c62fe698e4bc5541e6f92b241d0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
index dbb98cdcd203fbbfa6dfa8c83aa904e13ec38b3d..34f3afec9b5466e4fa75cdc7cd71c01ad53e0d5d 100644 (file)
@@ -2,6 +2,8 @@
 
 [ "$ACTION" = ifup ] || exit 0
 
+/etc/init.d/firewall enabled || exit 0
+
 fw3 -q network "$INTERFACE" >/dev/null || exit 0
 
 logger -t firewall "Reloading firewall due to ifup of $INTERFACE ($DEVICE)"
index 8c1dbd94caf6708a89212d5835bbe7c7429f8be6..64e3a8c12ba864bfd9b9f07e98687df84c41122d 100755 (executable)
@@ -13,9 +13,13 @@ start() {
 }
 
 stop() {
-       fw3 stop
+       fw3 flush
 }
 
 restart() {
        fw3 restart
 }
+
+reload() {
+       fw3 reload
+}