prereq: make existing binary check work for sdk as well
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 16 Aug 2023 09:22:30 +0000 (11:22 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 26 Oct 2023 23:03:38 +0000 (01:03 +0200)
To avoid replacing host built binaries with symlinks again, a check for
an appropriate stamp was added in 729909c07f ("prereq-build: do not
replace binaries with symlinks"). Unfortunately the stamp directory does
not exist in the SDK, so the fix was ineffective there.

This caused the packages builders to e.g. use the host tar again, which
in turn made the tarballs created different since it may lack
reproducibility fixes, or implement these differently, causing spurious
hash failures on source repository based packages.

Fix this by dropping the stamp dir check, and just check that the file
is usable.

Fixes: 729909c07f ("prereq-build: do not replace binaries with symlinks")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
(cherry picked from commit c1ef10c8d873254ce7c1f3019d821c4a87227474)

include/prereq.mk

index 88ed1f406afdb267a05ea97ae9adfa64af05a766..5cb11021824d24c3786aeca1b60a9f4c3816c209 100644 (file)
@@ -111,7 +111,6 @@ define SetupHostCommand
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                        "-"*) \
-                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                        *" -> /"*) \