ramips: add mt7615e support to Netgear R6350
authorChristoph Krapp <achterin@googlemail.com>
Thu, 29 Aug 2019 08:06:12 +0000 (10:06 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 20 Jan 2020 23:28:01 +0000 (00:28 +0100)
Signed-off-by: Christoph Krapp <achterin@googlemail.com>
(cherry picked from commit 9861fa7abab97cb928aaa6cd5732a413d973ac95)

target/linux/ramips/dts/R6350.dts
target/linux/ramips/image/mt7621.mk

index 538fa21ace792beac42c97d683ff017978f20823..00c9825750bfec6b29ba5403e7bf12ef28aa2c2f 100644 (file)
        status = "okay";
 };
 
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
 &pcie1 {
        wifi@0,0 {
                reg = <0x0 0 0 0 0>;
index 53a264f527a673dd9f1df5bc3cd6e0b60cf194db..fd3a8e558e4c0be533e2124760acd6412590844b 100644 (file)
@@ -374,7 +374,7 @@ define Device/netgear_r6350
   IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := Netgear R6350
   DEVICE_PACKAGES := \
-       kmod-mt7603 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+       kmod-mt7603 kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += netgear_r6350