ipq40xx: Convert mikrotik,wap-ac to DSA
authorMark Mentovai <mark@mentovai.com>
Thu, 11 Nov 2021 17:24:24 +0000 (12:24 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 19 Oct 2022 20:58:12 +0000 (22:58 +0200)
As done previously, this preserves the MAC addresses of they physical
Ethernet ports. The interfaces are renamed as eth0 is in use for the
native GMAC; the new interface naming matches the physical port labels.
 - sw-eth1 corresponds to the physical port labeled ETH1 and has the
   base MAC address. This port can be used to power the device.
 - sw-eth2 corresponds to the physical port labeled ETH2 and has a MAC
   address one greater than the base.

As this device has 2 physical ports, they are each connected to their
respective PHYs, allowing the link status to be visible to software.
Since they are not marked on the case with any role (such as LAN or
WAN), both are bridged to the lan network by default, although this can
easily be changed if needed.

Signed-off-by: Mark Mentovai <mark@mentovai.com>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/lib/preinit/05_set_iface_mac_ipq40xx.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dts
target/linux/ipq40xx/image/mikrotik.mk

index 1089a7f3f81d61d5a8203ac0ecf4f65201050d7a..36f1f7c24a55088e0b2dd6bebd7a8055a8ea1424 100644 (file)
@@ -52,11 +52,14 @@ ipq40xx_setup_interfaces()
        cellc,rtl30vw)
                ucidef_set_interface_lan "lan1 lan2"
                ;;
+       compex,wpj428)
+               ucidef_set_interface_lan "lan1 lan2"
+               ;;
        glinet,gl-b1300)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
-       compex,wpj428)
-               ucidef_set_interface_lan "lan1 lan2"
+       mikrotik,wap-ac)
+               ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
        zte,mf286d)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" "wan"
index 18c24e0511593656397da7b168085ba9d94ba55d..e4a5eb3e895f41d4eafacd2e9b971633bb7579c0 100644 (file)
@@ -26,8 +26,8 @@ preinit_set_mac_address() {
                ;;
        mikrotik,wap-ac)
                base_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
-               ip link set dev eth0 address "$base_mac"
-               ip link set dev eth1 address $(macaddr_add "$base_mac" 1)
+               ip link set dev sw-eth1 address "$base_mac"
+               ip link set dev sw-eth2 address $(macaddr_add "$base_mac" 1)
                ;;
        zyxel,nbg6617)
                base_mac=$(cat /sys/class/net/eth0/address)
index e6a6202216f758cb6583358b4f17316f39e1760d..ecbdfac15f81701a021301ec16f9af9aecf61be4 100644 (file)
        status = "okay";
 };
 
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport4 {
+       status = "okay";
+       label = "sw-eth2";
+};
+
+&swport5 {
+       status = "okay";
+       label = "sw-eth1";
+};
+
 &wifi0 {
        status = "okay";
 
index 8491ff4a42598fd24fd9f82d70ebb2f89c439881..d1f0829cd3f3d43d0e2a447847dac0058e0b030e 100644 (file)
@@ -69,5 +69,4 @@ define Device/mikrotik_wap-ac
        SOC := qcom-ipq4018
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += mikrotik_wap-ac
+TARGET_DEVICES += mikrotik_wap-ac