ath10k-ct: update to version 2019-08-14
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 16 Aug 2019 10:03:43 +0000 (12:03 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 27 Aug 2019 08:31:06 +0000 (10:31 +0200)
Changes:

9e5ab25027e0 ath10k-ct:  Update to latest 5.2 upstream, support bigger mtu, 160Mhz

Removed upstreamed patches:
- 204-ath10k-fix-max-antenna-gain-unit.patch
- 205-ath10k-adjust-tx-power-reduction-for-US-regulatory-d.patch

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/202-ath10k-4.16-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/203-ath10k-Limit-available-channels-via-DT-ieee80211-fre.patch
package/kernel/ath10k-ct/patches/204-ath10k-fix-max-antenna-gain-unit.patch [deleted file]
package/kernel/ath10k-ct/patches/205-ath10k-adjust-tx-power-reduction-for-US-regulatory-d.patch [deleted file]

index 89c0b43ad637b28bff3b3f50700ed41e8f752add..12f910dd7878826db499cde6a24a42f42a12656e 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-06-13
-PKG_SOURCE_VERSION:=f0aa81302b2286715fa2fa5a2f4ebe2faf17694c
-PKG_MIRROR_HASH:=a6d418dfec02842529a53b3c48236e7a375a654a03e199fbc5178bdb269b7d64
+PKG_SOURCE_DATE:=2019-08-14
+PKG_SOURCE_VERSION:=9e5ab25027e0971fa24ccf93373324c08c4e992d
+PKG_MIRROR_HASH:=afe555d1659fafa56368f2f3fa70f65e65d061447dfdc4b7bacb87436dd0a005
 
 # Build the 4.19 ath10k-ct driver version.  Other options are "-4.16", or
 # leave un-defined for 4.7 kernel.  Probably this should match as closely as
index 9fe4c3b860f6836b69749d50eeeeac0813289f09..1757b94e5e4ce748498909bfbc5658637d050331 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -9963,7 +9963,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9965,7 +9965,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
  
  #ifdef CPTCFG_MAC80211_LEDS
index 7a5b4fd21f7466c393cf7c86a6bbdb8fc19ef755..3a22fc74cbb1791f7baa3c8f28279f83f1a5d1a2 100644 (file)
@@ -29,7 +29,7 @@ Forwarded: https://patchwork.kernel.org/patch/10549245/
  #include <net/mac80211.h>
  #include <linux/etherdevice.h>
  #include <linux/acpi.h>
-@@ -9687,6 +9688,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9689,6 +9690,7 @@ int ath10k_mac_register(struct ath10k *a
                ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
        }
  
diff --git a/package/kernel/ath10k-ct/patches/204-ath10k-fix-max-antenna-gain-unit.patch b/package/kernel/ath10k-ct/patches/204-ath10k-fix-max-antenna-gain-unit.patch
deleted file mode 100644 (file)
index 9fafaa0..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Sven Eckelmann <seckelmann@datto.com>
-Date: Tue, 11 Jun 2019 13:58:35 +0200
-Subject: ath10k: fix max antenna gain unit
-
-Most of the txpower for the ath10k firmware is stored as twicepower (0.5 dB
-steps). This isn't the case for max_antenna_gain - which is still expected
-by the firmware as dB.
-
-The firmware is converting it from dB to the internal (twicepower)
-representation when it calculates the limits of a channel. This can be seen
-in tpc_stats when configuring "12" as max_antenna_gain. Instead of the
-expected 12 (6 dB), the tpc_stats shows 24 (12 dB).
-
-Tested on QCA9888 and IPQ4019 with firmware 10.4-3.5.3-00057.
-
-Fixes: 02256930d9b8 ("ath10k: use proper tx power unit")
-Signed-off-by: Sven Eckelmann <seckelmann@datto.com>
-
-Forwarded: https://patchwork.kernel.org/patch/10986723/
-
---- a/ath10k-4.19/mac.c
-+++ b/ath10k-4.19/mac.c
-@@ -1185,7 +1185,7 @@ static int ath10k_monitor_vdev_start(str
-       arg.channel.min_power = 0;
-       arg.channel.max_power = channel->max_power * 2;
-       arg.channel.max_reg_power = channel->max_reg_power * 2;
--      arg.channel.max_antenna_gain = channel->max_antenna_gain * 2;
-+      arg.channel.max_antenna_gain = channel->max_antenna_gain;
-       reinit_completion(&ar->vdev_setup_done);
-@@ -1627,7 +1627,7 @@ static int ath10k_vdev_start_restart(str
-       arg.channel.min_power = 0;
-       arg.channel.max_power = chandef->chan->max_power * 2;
-       arg.channel.max_reg_power = chandef->chan->max_reg_power * 2;
--      arg.channel.max_antenna_gain = chandef->chan->max_antenna_gain * 2;
-+      arg.channel.max_antenna_gain = chandef->chan->max_antenna_gain;
-       /* CT Firmware can support 32+ VDEVS, but can only support
-        * beacon-ing devs with dev ids 0 - 31 due to firmware limitations.
-@@ -3799,7 +3799,7 @@ static int ath10k_update_channel_list(st
-                       ch->min_power = 0;
-                       ch->max_power = channel->max_power * 2;
-                       ch->max_reg_power = channel->max_reg_power * 2;
--                      ch->max_antenna_gain = channel->max_antenna_gain * 2;
-+                      ch->max_antenna_gain = channel->max_antenna_gain;
-                       ch->reg_class_id = 0; /* FIXME */
-                       /* FIXME: why use only legacy modes, why not any
diff --git a/package/kernel/ath10k-ct/patches/205-ath10k-adjust-tx-power-reduction-for-US-regulatory-d.patch b/package/kernel/ath10k-ct/patches/205-ath10k-adjust-tx-power-reduction-for-US-regulatory-d.patch
deleted file mode 100644 (file)
index ff8631e..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-From: Sven Eckelmann <seckelmann@datto.com>
-Date: Wed, 28 Nov 2018 16:16:27 +0100
-Subject: ath10k: adjust tx power reduction for US regulatory domain
-
-FCC allows maximum antenna gain of 6 dBi. 15.247(b)(4):
-
-> (4) The conducted output power limit
-> specified in paragraph (b) of this section
-> is based on the use of antennas
-> with directional gains that do not exceed
-> 6 dBi. Except as shown in paragraph
-> (c) of this section, if transmitting
-> antennas of directional gain greater
-> than 6 dBi are used, the conducted
-> output power from the intentional radiator
-> shall be reduced below the stated
-> values in paragraphs (b)(1), (b)(2),
-> and (b)(3) of this section, as appropriate,
-> by the amount in dB that the
-> directional gain of the antenna exceeds
-> 6 dBi.
-
-https://www.gpo.gov/fdsys/pkg/CFR-2013-title47-vol1/pdf/CFR-2013-title47-vol1-sec15-247.pdf
-
-Signed-off-by: Sven Eckelmann <seckelmann@datto.com>
-
-Forwarded: no
-
---- a/ath10k-4.19/mac.c
-+++ b/ath10k-4.19/mac.c
-@@ -1153,6 +1153,40 @@ static inline int ath10k_vdev_setup_sync
-       return ar->last_wmi_vdev_start_status;
- }
-+static u32 ath10k_get_max_antenna_gain(struct ath10k *ar,
-+                                     u32 ch_max_antenna_gain)
-+{
-+      u32 max_antenna_gain;
-+
-+      if (ar->dfs_detector && ar->dfs_detector->region == NL80211_DFS_FCC) {
-+              /* FCC allows maximum antenna gain of 6 dBi. 15.247(b)(4):
-+               *
-+               * > (4) The conducted output power limit
-+               * > specified in paragraph (b) of this section
-+               * > is based on the use of antennas
-+               * > with directional gains that do not exceed
-+               * > 6 dBi. Except as shown in paragraph
-+               * > (c) of this section, if transmitting
-+               * > antennas of directional gain greater
-+               * > than 6 dBi are used, the conducted
-+               * > output power from the intentional radiator
-+               * > shall be reduced below the stated
-+               * > values in paragraphs (b)(1), (b)(2),
-+               * > and (b)(3) of this section, as appropriate,
-+               * > by the amount in dB that the
-+               * > directional gain of the antenna exceeds
-+               * > 6 dBi.
-+               *
-+               * https://www.gpo.gov/fdsys/pkg/CFR-2013-title47-vol1/pdf/CFR-2013-title47-vol1-sec15-247.pdf
-+               */
-+              max_antenna_gain = 6;
-+      } else {
-+              max_antenna_gain = 0;
-+      }
-+
-+      return max(ch_max_antenna_gain, max_antenna_gain);
-+}
-+
- static int ath10k_monitor_vdev_start(struct ath10k *ar, int vdev_id)
- {
-       struct cfg80211_chan_def *chandef = NULL;
-@@ -1185,7 +1219,8 @@ static int ath10k_monitor_vdev_start(str
-       arg.channel.min_power = 0;
-       arg.channel.max_power = channel->max_power * 2;
-       arg.channel.max_reg_power = channel->max_reg_power * 2;
--      arg.channel.max_antenna_gain = channel->max_antenna_gain;
-+      arg.channel.max_antenna_gain = ath10k_get_max_antenna_gain(ar,
-+                                              channel->max_antenna_gain);
-       reinit_completion(&ar->vdev_setup_done);
-@@ -1627,7 +1662,8 @@ static int ath10k_vdev_start_restart(str
-       arg.channel.min_power = 0;
-       arg.channel.max_power = chandef->chan->max_power * 2;
-       arg.channel.max_reg_power = chandef->chan->max_reg_power * 2;
--      arg.channel.max_antenna_gain = chandef->chan->max_antenna_gain;
-+      arg.channel.max_antenna_gain = ath10k_get_max_antenna_gain(ar,
-+                                      chandef->chan->max_antenna_gain);
-       /* CT Firmware can support 32+ VDEVS, but can only support
-        * beacon-ing devs with dev ids 0 - 31 due to firmware limitations.
-@@ -3799,7 +3835,8 @@ static int ath10k_update_channel_list(st
-                       ch->min_power = 0;
-                       ch->max_power = channel->max_power * 2;
-                       ch->max_reg_power = channel->max_reg_power * 2;
--                      ch->max_antenna_gain = channel->max_antenna_gain;
-+                      ch->max_antenna_gain = ath10k_get_max_antenna_gain(ar,
-+                                              channel->max_antenna_gain);
-                       ch->reg_class_id = 0; /* FIXME */
-                       /* FIXME: why use only legacy modes, why not any