ar71xx: create separate 'factory' and 'sysupgrade' images for the WRT160NL
authorGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:47 +0000 (18:27 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:47 +0000 (18:27 +0000)
The 'factory' image requires the garbage at the end of the image.
Flashing from the original web interface does not work without that.

SVN-Revision: 21168

target/linux/ar71xx/image/Makefile

index cd066f78ed1c2a39a66c46af135baea44a9b7e19..a5f02703c9fb591cc15e2afce197129071daf0a6 100644 (file)
@@ -320,7 +320,10 @@ define Image/Build/CyberTAN
                -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
        -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
                -i $(KDIR)/image.tmp \
-               -o $(call imgname,$(1),$(2)).bin
+               -o $(call imgname,$(1),$(2))-sysupgrade.bin
+       -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
+               -i $(KDIR)/image.tmp \
+               -o $(call imgname,$(1),$(2))-factory.bin
        rm $(KDIR)/image.tmp
 endef