base-files: rc.common: fix missing EXTRA_HELP texts
authorPeter Stadler <peter.stadler@student.uibk.ac.at>
Tue, 12 Nov 2019 14:54:53 +0000 (15:54 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 21:53:31 +0000 (22:53 +0100)
Commit ed5b9129d7a4 ("base-files: implement generic service_running")
has added EXTRA_HELP variable, thus overriding already available
EXTRA_HELP text available in other init scripts, resulting in the
missing help text from services like dropbear for example.

So fix this regression by appending EXTRA_HELP text provided by the
other init scripts into the one provided by the script itself.

Fixes: ed5b9129d7a4 ("base-files: implement generic service_running")
Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
[commit title/description facelift, fixes tag, fixed From:, pkg bump]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/base-files/Makefile
package/base-files/files/etc/rc.common

index b35d00cf9495ea9b22c5c1a71f38b863eb9ac216..0ca4d739f355ed76b33f7005cfd6bccb37128ba5 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=208
+PKG_RELEASE:=209
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index d3fa3be5058dcdd146bfaa5afa63b1fe77dabeff..dbe26ec3bd0c6d239c653669af7970c662e84d04 100755 (executable)
@@ -109,7 +109,7 @@ ${INIT_TRACE:+set -x}
        EXTRA_HELP="\
        running Check if service is running
        status  Service status
-       "
+${EXTRA_HELP}"
 
        . $IPKG_INSTROOT/lib/functions/procd.sh
        basescript=$(readlink "$initscript")