ath10k-ct: update to version 2019-09-09
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 09:58:54 +0000 (11:58 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 10:52:52 +0000 (12:52 +0200)
5e8cd86f90da ath10k-ct: Backport ap-vlan code from 5.2 to 4.20 and 4.19 drivers.
0c518586bd7f ath10k-ct: Fix a few warning splats.

Adds AP VLAN.
Refreshed all patches.

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/161-ath10k-add-support-for-configuring-management-packet.patch
package/kernel/ath10k-ct/patches/162-ath10k-fix-possible-out-of-bound-access-of-ath10k_ra.patch
package/kernel/ath10k-ct/patches/163-ath10k-fix-incorrect-multicast-broadcast-rate-settin.patch
package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
package/kernel/ath10k-ct/patches/201-ath10k-4.16_add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-4.16-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/203-ath10k-Limit-available-channels-via-DT-ieee80211-fre.patch

index 12f910dd7878826db499cde6a24a42f42a12656e..eee8b7d0d268ecd54bd5146c4ea942f75c56cf6c 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-08-14
-PKG_SOURCE_VERSION:=9e5ab25027e0971fa24ccf93373324c08c4e992d
-PKG_MIRROR_HASH:=afe555d1659fafa56368f2f3fa70f65e65d061447dfdc4b7bacb87436dd0a005
+PKG_SOURCE_DATE:=2019-09-09
+PKG_SOURCE_VERSION:=5e8cd86f90dac966d12df6ece84ac41458d0e95f
+PKG_MIRROR_HASH:=dc1097f3a7b4b7e346918f206746d00a0b7df07ae3be9b89be55dfaef3cbbe45
 
 # Build the 4.19 ath10k-ct driver version.  Other options are "-4.16", or
 # leave un-defined for 4.7 kernel.  Probably this should match as closely as
index d62a1cfcf5fc78706908aa0a20eb222f44da7a82..e67003c5a79d37243fa2c60ba6956cb916b6f945 100644 (file)
@@ -43,7 +43,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  static int ath10k_mac_get_max_vht_mcs_map(u16 mcs_map, int nss)
  {
        switch ((mcs_map >> (2 * nss)) & 0x3) {
-@@ -6388,9 +6404,10 @@ static void ath10k_bss_info_changed(stru
+@@ -6405,9 +6421,10 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -56,7 +56,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  
        mutex_lock(&ar->conf_mutex);
  
-@@ -6596,6 +6613,30 @@ static void ath10k_bss_info_changed(stru
+@@ -6613,6 +6630,30 @@ static void ath10k_bss_info_changed(stru
                                    arvif->vdev_id,  ret);
        }
  
index ab360b7261458c8de9a634b703ce5d9ef68de7c3..a24029983c55e30d78c02d4d7b55aceb7ed15f34 100644 (file)
@@ -26,7 +26,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
                if (ath10k_rates[i].bitrate == bitrate)
                        return hw_value_prefix | ath10k_rates[i].hw_value;
        }
-@@ -6619,22 +6619,22 @@ static void ath10k_bss_info_changed(stru
+@@ -6636,22 +6636,22 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 2b550e76df7eb0e1cfd80f25ffb5b9561e7679ac..f6fd75b7e5bc38763f339bc8917fa9e1ffa026b9 100644 (file)
@@ -17,7 +17,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6404,8 +6404,8 @@ static void ath10k_bss_info_changed(stru
+@@ -6421,8 +6421,8 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -28,7 +28,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
        enum nl80211_band band;
        const struct ieee80211_supported_band *sband;
  
-@@ -6578,7 +6578,11 @@ static void ath10k_bss_info_changed(stru
+@@ -6595,7 +6595,11 @@ static void ath10k_bss_info_changed(stru
        if (changed & BSS_CHANGED_MCAST_RATE &&
            !WARN_ON(ath10k_mac_vif_chan(arvif->vif, &def))) {
                band = def.chan->band;
index f15411853784e911261ecb4229b3eb5dfa023046..cd570a100979ce7fa3762d3c8851320bff11e34d 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6600,6 +6600,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6617,6 +6617,7 @@ static void ath10k_bss_info_changed(stru
                           "mac vdev %d mcast_rate %x\n",
                           arvif->vdev_id, rate);
  
@@ -19,7 +19,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->mcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6608,6 +6609,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6625,6 +6626,7 @@ static void ath10k_bss_info_changed(stru
                                    "failed to set mcast rate on vdev %i: %d\n",
                                    arvif->vdev_id,  ret);
  
@@ -27,7 +27,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->bcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6634,6 +6636,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6651,6 +6653,7 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 74c4158f59b3a554ac7eba0e89bd8def0a600e63..b454796fca70f4334b996cb4545155b86f03f71f 100644 (file)
@@ -210,7 +210,7 @@ v13:
  
  #include "htt.h"
  #include "htc.h"
-@@ -1137,7 +1138,6 @@ struct ath10k {
+@@ -1138,7 +1139,6 @@ struct ath10k {
        u32 low_5ghz_chan;
        u32 high_5ghz_chan;
        bool ani_enabled;
@@ -218,7 +218,7 @@ v13:
        bool p2p;
        bool ct_all_pkts_htt; /* CT firmware only: native-wifi for all pkts */
  
-@@ -1388,6 +1388,13 @@ struct ath10k {
+@@ -1389,6 +1389,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -562,7 +562,7 @@ v13:
  int ath10k_wmi_attach(struct ath10k *ar)
 --- a/ath10k-4.19/wmi.h
 +++ b/ath10k-4.19/wmi.h
-@@ -3044,6 +3044,41 @@ enum wmi_10_4_feature_mask {
+@@ -3084,6 +3084,41 @@ enum wmi_10_4_feature_mask {
  
  };
  
index 1757b94e5e4ce748498909bfbc5658637d050331..562137fd3095e229f0416f940b096b99ad9a811c 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
 
 --- a/ath10k-4.19/core.h
 +++ b/ath10k-4.19/core.h
-@@ -1487,6 +1487,10 @@ struct ath10k {
+@@ -1488,6 +1488,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -9965,7 +9965,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9982,7 +9982,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
  
  #ifdef CPTCFG_MAC80211_LEDS
index 3a22fc74cbb1791f7baa3c8f28279f83f1a5d1a2..d770948f79c0237a1e16a6c701a25e6f37522dc3 100644 (file)
@@ -29,7 +29,7 @@ Forwarded: https://patchwork.kernel.org/patch/10549245/
  #include <net/mac80211.h>
  #include <linux/etherdevice.h>
  #include <linux/acpi.h>
-@@ -9689,6 +9690,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9706,6 +9707,7 @@ int ath10k_mac_register(struct ath10k *a
                ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
        }