ath79: Port PowerCloud Systems CAP324 support
authorDaniel F. Dickinson <cshored@thecshore.com>
Sat, 28 Jul 2018 12:52:39 +0000 (08:52 -0400)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 08:43:31 +0000 (10:43 +0200)
The CAP324 was an AP for a NaaS offering that is now defunct.  While
previously supported in the ar71xx arch, there were some errata (to
be fixed shortly).

Notable differences from ar71xx support:

1) The method of getting the ath9k firmware for the PCIe 2ghz wifi has
changed (due to changes in how the arch handles this), since this device
doesn't use the EEPROM except to get the MAC address of the wifi.

2) /etc/config/wireless will need to be regenerated as the path(s) to
the wireless device(s) have changed.

3) ath79 OpenWrt firmware no longer supports build an image that allows
reverting to stock firmware (as the cloud service no longer exists, the
stock firmware is useless), instead using all of the flash for image and
overlay (less u-boot/env and art).

4) Initial network config treats the ethernet port as a Lan port with
the standard default address (192.168.1.1 unless changed in .config
--e.g. via menuconfig) instead of using DHCP (this was the default for
the stock firmware, however for openwrt use this is rather confusion and
counter-productive as the user has a harder time finding the device on
the network.

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/dts/ar9344_pcs_cap324.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index e8f4e1d14ea55b371b90c1c16412b80903152158..4fa4434efefaa5f85374ad144f76cc6eba38a3d0 100755 (executable)
@@ -29,6 +29,10 @@ case "$board" in
        ucidef_set_led_switch "lan2" "LAN2" "netgear:green:lan2" "switch0" "0x04" "0x0f"
        ;;
 
+"pcs,cap324")
+       ucidef_set_led_netdev "lan" "LAN" "pcs:lan:green" "eth0"
+       ;;
+
 "pcs,cr5000")
        ucidef_set_led_usbdev "usb" "USB" "pcs:white:wps" "1-1"
        ;;
index ca023f702f7860a357fe4d5b9d5a8a791b8e64ea..55c1a31e9fb475e9ab911938540ca1499c456189 100755 (executable)
@@ -14,6 +14,7 @@ ath79_setup_interfaces()
                ;;
        "avm,fritz300e"|\
        "ocedo,raccoon"|\
+       "pcs,cap324"|\
        "tplink,re450-v2"|\
        "tplink,tl-mr10u"|\
        "tplink,tl-wr703n"|\
index e1f0f521c83f7dc682d01bf8a177b9b66f0f0a6e..a687239d44b61bca680d74732f52b94dd8ed8405 100644 (file)
@@ -57,6 +57,7 @@ case "$FIRMWARE" in
                ;;
        "netgear,wnr612-v2"|\
        "on,n150r"|\
+       "pcs,cap324"|\
        "tplink,tl-mr3220-v1"|\
        "tplink,tl-mr3420-v1"|\
        "tplink,tl-wr740n-v2"|\
diff --git a/target/linux/ath79/dts/ar9344_pcs_cap324.dts b/target/linux/ath79/dts/ar9344_pcs_cap324.dts
new file mode 100644 (file)
index 0000000..57cf816
--- /dev/null
@@ -0,0 +1,179 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9344.dtsi"
+
+/ {
+       model = "PowerCloud Systems CAP324";
+       compatible = "pcs,cap324", "qca,ar9344";
+
+       aliases {
+               serial0 = &uart;
+               led-status = &status;
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+               #address-cells = <1>;
+               #size-cells = <0>;
+               pinctrl-names = "default";
+                pinctrl-0 = <&jtag_disable_pins>;
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power_amber {
+                       label = "pcs:amber:power";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               status: power_green {
+                       label = "pcs:green:power";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wlan_amber {
+                       label = "pcs:amber:wlan";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wlan_green {
+                       label = "pcs:green:wlan";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               lan_amber {
+                       label = "pcs:lan:amber";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               lan_green {
+                       label = "pcs:lan:green";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+};
+
+&ref {
+       clock-frequency = <25000000>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&spi {
+       num-cs = <1>;
+
+       status = "okay";
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x050000 0x0fa0000>;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+
+        ath9k: wifi@168c,0030 {
+               compatible = "168c,0030";
+               reg = <0x0000 0 0 0 0>;
+               mtd-mac-address = <&art 0x0>;
+               mtd-mac-address-increment = <(-2)>;
+               mtd-cal-data = <&art 0x5000>;
+               qca,no-eeprom;
+               qca,disable-5ghz;
+               #gpio-cells = <2>;
+               gpio-controller;
+        };
+};
+
+&wmac {
+       status = "okay";
+
+       qca,disable-2ghz;
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x0>;
+       mtd-mac-address-increment = <(-1)>;
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "rgmii";
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       /* default for ar934x, except for 1000M */
+       pll-data = <0x06000000 0x00000101 0x00001616>;
+
+       mtd-mac-address = <&art 0x0>;
+
+       phy-mode = "rgmii";
+       phy-handle = <&phy0>;
+};
index d8897784eadfebd7c3db083074c1b85fa1ecfe14..769534970592dfa7622a4407375e4dd767e3b001 100644 (file)
@@ -66,6 +66,15 @@ define Device/openmesh_om5p-ac-v2
 endef
 TARGET_DEVICES += openmesh_om5p-ac-v2
 
+define Device/pcs_cap324
+  ATH_SOC := ar9344
+  DEVICE_TITLE := PowerCloud Systems CAP324
+  IMAGE_SIZE := 16000k
+  IMAGES := sysupgrade.bin
+  SUPPORTED_DEVICES += cap324
+endef
+TARGET_DEVICES += pcs_cap324
+
 define Device/pcs_cr5000
   ATH_SOC := ar9344
   DEVICE_TITLE := PowerCloud Systems CR5000