tools: m4: set -std=gnu17
authorRobert Marko <robimarko@gmail.com>
Wed, 16 Apr 2025 09:42:54 +0000 (11:42 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 16 Apr 2025 11:52:33 +0000 (13:52 +0200)
Fedora 42 updated to GCC15 which now defaults to GNU23 as the default
instead of GNU17[1], and this breaks m4 compilation.

Its been reported upstream [2], so until its fixed lets simply set C
language version back to GNU17.

[1] https://gcc.gnu.org/gcc-15/porting_to.html#c23
[2] https://savannah.gnu.org/support/?111150

Link: https://github.com/openwrt/openwrt/pull/18505
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/m4/Makefile

index ee369f3cbb3d995f9103a6d2acfa2d5923e32a72..c13155397d25f343601314af0b076d530ebdef94 100644 (file)
@@ -18,6 +18,7 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CFLAGS += -std=gnu17
 HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
 
 define Host/Uninstall