ipq40xx: convert devolo Magic 2 WiFi next to DSA
authorThomas Bong <thomas.bong@devolo.de>
Thu, 31 Aug 2023 05:39:24 +0000 (07:39 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 3 Sep 2023 21:11:40 +0000 (23:11 +0200)
Renamed the interfaces to match the other devices.
Name the interface connected to the builtin G.hn chip 'ghn'.
This might toggle at runtime while the G.hn chip is in the
bootloader.

Reviewed-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Thomas Bong <thomas.bong@devolo.de>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts
target/linux/ipq40xx/image/generic.mk

index 77dc892d078874950d52f597a788eb6245fdd553..951e0ad0444ba3b6ad8772cf3473177a43a3e55e 100644 (file)
@@ -69,6 +69,9 @@ ipq40xx_setup_interfaces()
        compex,wpj428)
                ucidef_set_interface_lan "lan1 lan2"
                ;;
+       devolo,magic-2-wifi-next)
+               ucidef_set_interface_lan "lan1 lan2 ghn"
+               ;;
        linksys,whw01)
                ucidef_set_interface_lan "eth1 eth2"
                ;;
index 29d51aa9e1c57eb6042de3122d5d83775d13f9f2..1fbc02d62b28d349ae5a932d7e2c13f957278693 100644 (file)
                };
        };
 };
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport5 {
+       status = "okay";
+       label = "lan1";
+};
+
+&swport3 {
+       status = "okay";
+       label = "lan2";
+};
+
+&swport4 {
+       status = "okay";
+       label = "ghn";
+};
index 56aad5062ed16dafd24a3d89a5e120d1dc9a4cdf..58836471f0c63f67416983a30bbf15d18be332ef 100644 (file)
@@ -388,7 +388,7 @@ define Device/devolo_magic-2-wifi-next
        DEFAULT := n
 endef
 # Missing DSA Setup
-#TARGET_DEVICES += devolo_magic-2-wifi-next
+TARGET_DEVICES += devolo_magic-2-wifi-next
 
 define Device/dlink_dap-2610
        $(call Device/FitImageLzma)