uboot-mediatek: don't rely in 'lzma' cmdline
authorDaniel Golle <daniel@makrotopia.org>
Thu, 18 Mar 2021 04:18:05 +0000 (04:18 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 18 Mar 2021 04:19:48 +0000 (04:19 +0000)
Use 'xz --format=lzma' instead.
Fixes build for mt7629.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/uboot-mediatek/patches/010-ahci-mediatek-fix-missing-dev_err-definition.patch
package/boot/uboot-mediatek/patches/120-use-xz-instead-of-lzma.patch [new file with mode: 0644]

index 5e2b4aa39bc0082cc64cc520d0345b0baa20f5cd..448bf7b8657a57ab68412a629fdab4053e5ac13a 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH] ahci: mediatek: fix missing dev_err definition
  drivers/ata/mtk_ahci.c | 1 +
  1 file changed, 1 insertion(+)
 
-diff --git a/drivers/ata/mtk_ahci.c b/drivers/ata/mtk_ahci.c
-index 554175bc00..2c5227df30 100644
 --- a/drivers/ata/mtk_ahci.c
 +++ b/drivers/ata/mtk_ahci.c
 @@ -21,6 +21,7 @@
@@ -19,6 +17,3 @@ index 554175bc00..2c5227df30 100644
  
  #define SYS_CFG                       0x14
  #define SYS_CFG_SATA_MSK      GENMASK(31, 30)
--- 
-2.30.2
-
diff --git a/package/boot/uboot-mediatek/patches/120-use-xz-instead-of-lzma.patch b/package/boot/uboot-mediatek/patches/120-use-xz-instead-of-lzma.patch
new file mode 100644 (file)
index 0000000..d33b0b9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1008,7 +1008,7 @@ quiet_cmd_pad_cat = CAT     $@
+ cmd_pad_cat = $(cmd_objcopy) && $(append) || { rm -f $@; false; }
+ quiet_cmd_lzma = LZMA    $@
+-cmd_lzma = lzma -c -z -k -9 $< > $@
++cmd_lzma = xz --format=lzma -c -z -k -9 $< > $@
+ cfg: u-boot.cfg