kernel: bump 4.9 to 4.9.125
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 6 Sep 2018 12:17:17 +0000 (14:17 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 7 Sep 2018 15:22:23 +0000 (17:22 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/903-at803x-add-sgmii-aneg-override-pdata.patch
target/linux/ar71xx/patches-4.9/940-qca955x-add-more-registers.patch
target/linux/brcm47xx/patches-4.9/830-huawei_e970_support.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 425c7ab594e005246c1af2488a2f0310fb274b27..3e31f6ca7c2462c0f9f5af6504da48b0a7670739 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .124
 LINUX_VERSION-4.14 = .67
+LINUX_VERSION-4.9 = .125
 
-LINUX_KERNEL_HASH-4.9.124 = 5ca6b0d48c8dd1265005169f1b97149a4e893668c0d8aa566a73c7663c8e4311
 LINUX_KERNEL_HASH-4.14.67 = 3f4b056dc27233a78f7a4a35ed6fdcfd0a9680ec40b611a898bb6c8b905070ba
+LINUX_KERNEL_HASH-4.9.125 = a764deef61bebfac1d07b2ed6890f93a12a9ab6d3fc3c53e3d850ed4681111cb
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 9c922d155d075505d0fc6186176990922e1698f6..fc640af17d3069b4cddb268aff0a79defba96b37 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-4.9.111/drivers/net/phy/at803x.c
-===================================================================
---- linux-4.9.111.orig/drivers/net/phy/at803x.c
-+++ linux-4.9.111/drivers/net/phy/at803x.c
-@@ -461,12 +461,15 @@ static void at803x_link_change_notify(st
+--- a/drivers/net/phy/at803x.c
++++ b/drivers/net/phy/at803x.c
+@@ -460,12 +460,15 @@ static void at803x_link_change_notify(st
  
  static int at803x_aneg_done(struct phy_device *phydev)
  {
@@ -18,7 +16,7 @@ Index: linux-4.9.111/drivers/net/phy/at803x.c
        /*
         * in SGMII mode, if copper side autoneg is successful,
         * also check SGMII side autoneg result
-@@ -481,7 +484,8 @@ static int at803x_aneg_done(struct phy_d
+@@ -480,7 +483,8 @@ static int at803x_aneg_done(struct phy_d
        /* check if the SGMII link is OK. */
        if (!(phy_read(phydev, AT803X_PSSR) & AT803X_PSSR_MR_AN_COMPLETE)) {
                pr_warn("803x_aneg_done: SGMII link is not ok\n");
@@ -28,10 +26,8 @@ Index: linux-4.9.111/drivers/net/phy/at803x.c
        }
        /* switch back to copper page */
        phy_write(phydev, AT803X_REG_CHIP_CONFIG, ccr | AT803X_BT_BX_REG_SEL);
-Index: linux-4.9.111/include/linux/platform_data/phy-at803x.h
-===================================================================
---- linux-4.9.111.orig/include/linux/platform_data/phy-at803x.h
-+++ linux-4.9.111/include/linux/platform_data/phy-at803x.h
+--- a/include/linux/platform_data/phy-at803x.h
++++ b/include/linux/platform_data/phy-at803x.h
 @@ -7,6 +7,7 @@ struct at803x_platform_data {
        int enable_rgmii_rx_delay:1;
        int fixup_rgmii_tx_delay:1;
index 97400e3ec88cf910054fa9366758077c75912c5a..ff723084651ab6209ae79fd7a98804841f85bdea 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-4.9.111/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
-===================================================================
---- linux-4.9.111.orig/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
-+++ linux-4.9.111/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
+--- a/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
++++ b/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
 @@ -134,7 +134,7 @@
  #define QCA955X_PCI_CTRL_SIZE 0x100
  
index 5d40fe6541616dbe23927fa623326d5a8a9728e3..b6150ed8fd9763ca3534e32173407afa5d6853c9 100644 (file)
@@ -8,7 +8,7 @@
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
  #include <asm/prom.h>
-@@ -231,6 +232,33 @@ static struct fixed_phy_status bcm47xx_f
+@@ -225,6 +226,33 @@ static struct fixed_phy_status bcm47xx_f
        .duplex = DUPLEX_FULL,
  };
  
@@ -42,7 +42,7 @@
  static int __init bcm47xx_register_bus_complete(void)
  {
        switch (bcm47xx_bus_type) {
-@@ -250,6 +278,7 @@ static int __init bcm47xx_register_bus_c
+@@ -244,6 +272,7 @@ static int __init bcm47xx_register_bus_c
        bcm47xx_workarounds();
  
        fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status, -1);
index 127707827e21c9a7fd5d5761a1c7b8a32d2f071e..3268b3407ac0c6a8e7e197daccd594ef43007a8c 100644 (file)
@@ -302,7 +302,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (alx->flags & ALX_FLAG_USING_MSIX) {
 --- a/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
 +++ b/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
-@@ -1885,7 +1885,7 @@ static int atl1c_clean(struct napi_struc
+@@ -1886,7 +1886,7 @@ static int atl1c_clean(struct napi_struc
  
        if (work_done < budget) {
  quit_polling:
index 7afef36e4be8b07760a56c2932acee615200441e..3c278099d3fc781d83dc4fc6295462ef45ba2910 100644 (file)
@@ -1658,7 +1658,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                        return IRQ_HANDLED;
                }
        }
-@@ -923,12 +932,32 @@ int usb_otg_start(struct platform_device
+@@ -925,12 +934,32 @@ int usb_otg_start(struct platform_device
        temp &= ~(PORTSC_PHY_TYPE_SEL | PORTSC_PTW);
        switch (pdata->phy_mode) {
        case FSL_USB2_PHY_ULPI: